mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-21 14:37:57 +00:00
738b04c881
Removed upstreamed:
pending-5.15/101-Use-stddefs.h-instead-of-compiler.h.patch[1]
ipq806x/patches-5.15/122-01-clk-qcom-clk-krait-fix-wrong-div2-functions.patch[2]
bcm27xx/patches-5.15/950-0198-drm-fourcc-Add-packed-10bit-YUV-4-2-0-format.patch[3]
Manually rebased:
ramips/patches-5.15/100-PCI-mt7621-Add-MediaTek-MT7621-PCIe-host-controller-.patch[4]
Added patch/backported:
ramips/patches-5.15/107-PCI-mt7621-Add-sentinel-to-quirks-table.patch[5]
All other patches automatically rebased.
1. https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=v5.15.86&id=c160505c9b574b346031fdf2c649d19e7939ca11
2. https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=v5.15.86&id=a051e10bfc6906d29dae7a31f0773f2702edfe1b
3. https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=v5.15.86&id=ec1727f89ecd6f2252c0c75e200058819f7ce47a
4. Quilt gave this output when I applied the patch to rebase it:
% quilt push -f
Applying patch platform/100-PCI-mt7621-Add-MediaTek-MT7621-PCIe-host-controller-.patch
patching file arch/mips/ralink/Kconfig
patching file drivers/pci/controller/Kconfig
patching file drivers/pci/controller/Makefile
patching file drivers/staging/Kconfig
patching file drivers/staging/Makefile
patching file drivers/staging/mt7621-pci/Kconfig
patching file drivers/staging/mt7621-pci/Makefile
patching file drivers/staging/mt7621-pci/TODO
patching file drivers/staging/mt7621-pci/mediatek,mt7621-pci.txt
patching file drivers/staging/mt7621-pci/pci-mt7621.c
Hunk #1 FAILED at 1.
Not deleting file drivers/staging/mt7621-pci/pci-mt7621.c as content differs from patch
1 out of 1 hunk FAILED -- saving rejects to file drivers/staging/mt7621-pci/pci-mt7621.c.rej
patching file drivers/pci/controller/pcie-mt7621.c
Applied patch platform/100-PCI-mt7621-Add-MediaTek-MT7621-PCIe-host-controller-.patch (forced; needs refresh)
Upon inspecting drivers/staging/mt7621-pci/pci-mt7621.c.rej, it seems that
the original patch wants to delete drivers/staging/mt7621-pci/pci-mt7621.c
but upstream's version was not an exact match. I opted to delete that
file.
5. Suggestion by hauke: 19098934f9
"This patch is in upstream kernel, but it was backported to the old
staging driver in kernel 5.15."
Build system: x86_64
Build-tested: bcm2711/RPi4B, filogic/xiaomi_redmi-router-ax6000-ubootmod
Run-tested: bcm2711/RPi4B, filogic/xiaomi_redmi-router-ax6000-ubootmod
Signed-off-by: John Audia <therealgraysky@proton.me>
48 lines
1.6 KiB
Diff
48 lines
1.6 KiB
Diff
From 02b606fbd70b9226e851d969828a1499cb7869bf Mon Sep 17 00:00:00 2001
|
|
From: Luke Hinds <7058938+lukehinds@users.noreply.github.com>
|
|
Date: Wed, 22 Jan 2020 16:03:00 +0000
|
|
Subject: [PATCH] Initialise rpi-firmware before clk-bcm2835
|
|
|
|
The IMA (Integrity Measurement Architecture) looks for a TPM (Trusted
|
|
Platform Module) having been registered when it initialises; otherwise
|
|
it assumes there is no TPM. It has been observed on BCM2835 that IMA
|
|
is initialised before TPM, and that initialising the BCM2835 clock
|
|
driver before the firmware driver has the effect of reversing this
|
|
order.
|
|
|
|
Change the firmware driver to initialise at core_initcall, delaying the
|
|
BCM2835 clock driver to postcore_initcall.
|
|
|
|
See: https://github.com/raspberrypi/linux/issues/3291
|
|
https://github.com/raspberrypi/linux/pull/3297
|
|
|
|
Signed-off-by: Luke Hinds <lhinds@redhat.com>
|
|
Co-authored-by: Phil Elwell <phil@raspberrypi.org>
|
|
---
|
|
drivers/clk/bcm/clk-bcm2835.c | 2 +-
|
|
drivers/firmware/raspberrypi.c | 2 +-
|
|
2 files changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
--- a/drivers/clk/bcm/clk-bcm2835.c
|
|
+++ b/drivers/clk/bcm/clk-bcm2835.c
|
|
@@ -2454,7 +2454,7 @@ static int __init __bcm2835_clk_driver_i
|
|
{
|
|
return platform_driver_register(&bcm2835_clk_driver);
|
|
}
|
|
-core_initcall(__bcm2835_clk_driver_init);
|
|
+postcore_initcall(__bcm2835_clk_driver_init);
|
|
|
|
MODULE_AUTHOR("Eric Anholt <eric@anholt.net>");
|
|
MODULE_DESCRIPTION("BCM2835 clock driver");
|
|
--- a/drivers/firmware/raspberrypi.c
|
|
+++ b/drivers/firmware/raspberrypi.c
|
|
@@ -499,7 +499,7 @@ out2:
|
|
out1:
|
|
return ret;
|
|
}
|
|
-subsys_initcall(rpi_firmware_init);
|
|
+core_initcall(rpi_firmware_init);
|
|
|
|
static void __init rpi_firmware_exit(void)
|
|
{
|