openwrt/target/linux/mediatek/patches-4.19/0003-switch-add-mt7531.patch
John Crispin 66458c49aa mediatek: add v4.19 support
Bump the target to v4.19. Add a patch with additional eth driver
fixes/features that MTK provided aswell as the driver for the new mt7530
switch.

Signed-off-by: John Crispin <john@phrozen.org>
2019-08-02 10:36:11 +02:00

24 lines
815 B
Diff

Index: linux-4.19.57/drivers/net/phy/Kconfig
===================================================================
--- linux-4.19.57.orig/drivers/net/phy/Kconfig
+++ linux-4.19.57/drivers/net/phy/Kconfig
@@ -292,6 +292,8 @@ config RTL8367B_PHY
endif # RTL8366_SMI
+source "drivers/net/phy/mtk/mt753x/Kconfig"
+
comment "MII PHY device drivers"
config SFP
Index: linux-4.19.57/drivers/net/phy/Makefile
===================================================================
--- linux-4.19.57.orig/drivers/net/phy/Makefile
+++ linux-4.19.57/drivers/net/phy/Makefile
@@ -100,3 +100,5 @@ obj-$(CONFIG_STE10XP) += ste10Xp.o
obj-$(CONFIG_TERANETICS_PHY) += teranetics.o
obj-$(CONFIG_VITESSE_PHY) += vitesse.o
obj-$(CONFIG_XILINX_GMII2RGMII) += xilinx_gmii2rgmii.o
+obj-$(CONFIG_MT753X_GSW) += mtk/mt753x/
+