mirror of
https://github.com/openwrt/openwrt.git
synced 2025-01-07 14:28:50 +00:00
e1d6013935
Source archive format changed to tar.xz Removed upstreamed 020-treewide-use-uint-instead-of-u_int.patch 030-revert-fix-build-for-missing-ETH_ALEN-definition.patch 040-xshared-Fix-build-for-Werror-format-security.patch 050-build-fix-error-during-out-of-tree-build.patch 060-libxtables-unexport-init_extensions-declarations.patch 070-extensions-string-Review-parse_string-function.patch 104-nft-track-each-register-individually.patch Manually rebased 600-shared-libext.patch Change netfiletr.mk due to module name change https://git.netfilter.org/iptables/commit/?id=f30c5edce0413b2b2346c7f58e801f10f6e9bc5a Signed-off-by: Ivan Pavlov <AuthorReflex@gmail.com> Link: https://github.com/openwrt/openwrt/pull/16641 Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
29 lines
881 B
Diff
29 lines
881 B
Diff
--- a/libxtables/xtables.c
|
|
+++ b/libxtables/xtables.c
|
|
@@ -1095,12 +1095,6 @@ void xtables_register_match(struct xtabl
|
|
struct xtables_match **pos;
|
|
bool seen_myself = false;
|
|
|
|
- if (me->next) {
|
|
- fprintf(stderr, "%s: match \"%s\" already registered\n",
|
|
- xt_params->program_name, me->name);
|
|
- exit(1);
|
|
- }
|
|
-
|
|
if (me->version == NULL) {
|
|
fprintf(stderr, "%s: match %s<%u> is missing a version\n",
|
|
xt_params->program_name, me->name, me->revision);
|
|
@@ -1279,12 +1273,6 @@ void xtables_register_target(struct xtab
|
|
struct xtables_target **pos;
|
|
bool seen_myself = false;
|
|
|
|
- if (me->next) {
|
|
- fprintf(stderr, "%s: target \"%s\" already registered\n",
|
|
- xt_params->program_name, me->name);
|
|
- exit(1);
|
|
- }
|
|
-
|
|
if (me->version == NULL) {
|
|
fprintf(stderr, "%s: target %s<%u> is missing a version\n",
|
|
xt_params->program_name, me->name, me->revision);
|