mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-28 17:48:58 +00:00
fce11f6849
Creates RTL83XX as a basic kernel config parameter for the RTL838X, RTL839x, RTL930X and RTL931X platforms with respective configurations for the SoCs, which are introduced in addition. Signed-off-by: Birger Koblitz <git@birger-koblitz.de>
26 lines
920 B
Diff
26 lines
920 B
Diff
--- a/drivers/gpio/Kconfig
|
|
+++ b/drivers/gpio/Kconfig
|
|
@@ -508,6 +508,12 @@ config GPIO_REG
|
|
A 32-bit single register GPIO fixed in/out implementation. This
|
|
can be used to represent any register as a set of GPIO signals.
|
|
|
|
+config GPIO_RTL8231
|
|
+ tristate "RTL8231 GPIO"
|
|
+ depends on RTL83XX
|
|
+ help
|
|
+ Say yes here to support Realtek RTL8231 GPIO expansion chips.
|
|
+
|
|
config GPIO_SAMA5D2_PIOBU
|
|
tristate "SAMA5D2 PIOBU GPIO support"
|
|
depends on MFD_SYSCON
|
|
--- a/drivers/gpio/Makefile
|
|
+++ b/drivers/gpio/Makefile
|
|
@@ -126,6 +126,7 @@ obj-$(CONFIG_GPIO_RDA) += gpio-rda.o
|
|
obj-$(CONFIG_GPIO_RDC321X) += gpio-rdc321x.o
|
|
obj-$(CONFIG_GPIO_REALTEK_OTTO) += gpio-realtek-otto.o
|
|
obj-$(CONFIG_GPIO_REG) += gpio-reg.o
|
|
+obj-$(CONFIG_GPIO_RTL8231) += gpio-rtl8231.o
|
|
obj-$(CONFIG_ARCH_SA1100) += gpio-sa1100.o
|
|
obj-$(CONFIG_GPIO_SAMA5D2_PIOBU) += gpio-sama5d2-piobu.o
|
|
obj-$(CONFIG_GPIO_SCH311X) += gpio-sch311x.o
|