mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-26 00:41:17 +00:00
49cb5e501a
Use 'make target/linux/refresh' to refresh hack patches. Signed-off-by: Ansuel Smith <ansuelsmth@gmail.com>
24 lines
604 B
Diff
24 lines
604 B
Diff
--- a/drivers/mtd/nand/Kconfig
|
|
+++ b/drivers/mtd/nand/Kconfig
|
|
@@ -46,6 +46,10 @@ config MTD_NAND_ECC_SW_BCH
|
|
ECC codes. They are used with NAND devices requiring more than 1 bit
|
|
of error correction.
|
|
|
|
+config MTD_NAND_MTK_BMT
|
|
+ bool "Support MediaTek NAND Bad-block Management Table"
|
|
+ default n
|
|
+
|
|
endmenu
|
|
|
|
endmenu
|
|
--- a/drivers/mtd/nand/Makefile
|
|
+++ b/drivers/mtd/nand/Makefile
|
|
@@ -2,6 +2,7 @@
|
|
|
|
nandcore-objs := core.o bbt.o
|
|
obj-$(CONFIG_MTD_NAND_CORE) += nandcore.o
|
|
+obj-$(CONFIG_MTD_NAND_MTK_BMT) += mtk_bmt.o mtk_bmt_v2.o mtk_bmt_bbt.o mtk_bmt_nmbm.o
|
|
|
|
obj-y += onenand/
|
|
obj-y += raw/
|