mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-23 15:32:33 +00:00
53ab9865c2
Signed-off-by: David Bauer <mail@david-bauer.net> [refreshed] Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com> * Sync the patches with the changes done for kernel 4.19 * Use KERNEL_TESTING_PATCHVER * Refresh the configuration * Fix multiple compile bugs in the patches * Only add own ag71xx files for kernel 4.19 and use upstream version for 5.4. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
30 lines
1.2 KiB
Diff
30 lines
1.2 KiB
Diff
From c9395ad54e2cabb87d408becc37566f3d8248933 Mon Sep 17 00:00:00 2001
|
|
From: Christian Lamparter <chunkeey@gmail.com>
|
|
Date: Sun, 1 Dec 2019 02:08:23 +0100
|
|
Subject: [PATCH] powerpc: bootwrapper: force gzip as mkimage's compression
|
|
method
|
|
|
|
Due to CONFIG_KERNEL_XZ symbol, the bootwrapper code tries to
|
|
instruct the mkimage to use the xz compression, which isn't
|
|
supported. This patch forces the gzip compression, which is
|
|
supported and doesn't matter because the generated uImage for
|
|
the apm821xx target gets ignored as the OpenWrt toolchain will
|
|
do separate U-Boot kernel images for each device individually.
|
|
|
|
Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
|
|
---
|
|
arch/powerpc/boot/Makefile | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
--- a/arch/powerpc/boot/Makefile
|
|
+++ b/arch/powerpc/boot/Makefile
|
|
@@ -254,7 +254,7 @@ compressor-$(CONFIG_KERNEL_LZO) := lzo
|
|
|
|
# args (to if_changed): 1 = (this rule), 2 = platform, 3 = dts 4=dtb 5=initrd
|
|
quiet_cmd_wrap = WRAP $@
|
|
- cmd_wrap =$(CONFIG_SHELL) $(wrapper) -Z $(compressor-y) -c -o $@ -p $2 \
|
|
+ cmd_wrap =$(CONFIG_SHELL) $(wrapper) -Z gzip -c -o $@ -p $2 \
|
|
$(CROSSWRAP) $(if $3, -s $3)$(if $4, -d $4)$(if $5, -i $5) \
|
|
vmlinux
|
|
|