mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-27 01:11:14 +00:00
667f6c7f49
Manually rebased patches: bcm27xx/patches-5.4/950-0135-spi-spi-bcm2835-Disable-forced-software-CS.patch generic-backport/744-v5.5-net-sfp-soft-status-and-control-support.patch layerscape/patches-5.4/819-uart-0005-tty-serial-fsl_lpuart-enable-dma-mode-for-imx8qxp.patch mvebu/patches-5.4/521-arm64-dts-marvell-espressobin-Add-ethernet-switch-al.patch Removed: layerscape/patches-5.4/819-uart-0012-tty-serial-lpuart-add-LS1028A-support.patch All modifications made by update_kernel.sh Build system: x86_64 Build-tested: ipq806x/R7800, ath79/generic, bcm27xx/bcm2711, lantiq/Easybox 904 xDSL, x86_64 Run-tested: ipq806x/R7800, lantiq/Easybox 904 xDSL, x86_64 No dmesg regressions, everything functional Signed-off-by: John Audia <graysky@archlinux.us> Co-developed-by: Adrian Schmutzler <freifunk@adrianschmutzler.de> Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
27 lines
780 B
Diff
27 lines
780 B
Diff
--- a/drivers/net/phy/Kconfig
|
|
+++ b/drivers/net/phy/Kconfig
|
|
@@ -584,6 +584,13 @@ config MDIO_IPQ40XX
|
|
This driver supports the MDIO interface found in Qualcomm
|
|
Atheros ipq40xx Soc chip.
|
|
|
|
+config AR40XX_PHY
|
|
+ tristate "Driver for Qualcomm Atheros IPQ40XX switches"
|
|
+ depends on HAS_IOMEM && OF
|
|
+ select SWCONFIG
|
|
+ help
|
|
+ This is the driver for Qualcomm Atheros IPQ40XX ESS switches.
|
|
+
|
|
endif # PHYLIB
|
|
|
|
config MICREL_KS8995MA
|
|
--- a/drivers/net/phy/Makefile
|
|
+++ b/drivers/net/phy/Makefile
|
|
@@ -69,6 +69,7 @@ ifdef CONFIG_HWMON
|
|
aquantia-objs += aquantia_hwmon.o
|
|
endif
|
|
obj-$(CONFIG_AQUANTIA_PHY) += aquantia.o
|
|
+obj-$(CONFIG_AR40XX_PHY) += ar40xx.o
|
|
obj-$(CONFIG_AX88796B_PHY) += ax88796b.o
|
|
obj-$(CONFIG_AT803X_PHY) += at803x.o
|
|
obj-$(CONFIG_BCM63XX_PHY) += bcm63xx.o
|