mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-28 09:39:00 +00:00
c608f70325
Qualcomm SSDK is driver for Qualcomm Atheros switches and PHY-s. It is quite complicated and used by rest of the Qualcomm SDK stack for anything switch or PHY related. It is required for IPQ807x support as currently, there is no better driver for the built-in switch or UNIPHY. So, lets add the fixed-up version that supports kernel 5.15 for use on ipq807x target until a better driver is available. Signed-off-by: Alexandru Gagniuc <mr.nuke.me@gmail.com> Signed-off-by: Robert Marko <robimarko@gmail.com>
57 lines
1.7 KiB
Diff
57 lines
1.7 KiB
Diff
From 0c509f8d8e5a6a03933a112d4487fd1c005442d6 Mon Sep 17 00:00:00 2001
|
|
From: Robert Marko <robimarko@gmail.com>
|
|
Date: Fri, 24 Dec 2021 19:39:02 +0100
|
|
Subject: [PATCH 05/11] SSDK: config: add kernel 5.15
|
|
|
|
This is purely to identify it and be able to set
|
|
flags correctly.
|
|
|
|
Signed-off-by: Robert Marko <robimarko@gmail.com>
|
|
---
|
|
config | 6 +++++-
|
|
make/linux_opt.mk | 4 ++--
|
|
2 files changed, 7 insertions(+), 3 deletions(-)
|
|
|
|
--- a/config
|
|
+++ b/config
|
|
@@ -28,6 +28,10 @@ ifeq ($(KVER),$(filter 5.10%,$(KVER)))
|
|
OS_VER=5_10
|
|
endif
|
|
|
|
+ifeq ($(KVER),$(filter 5.15%,$(KVER)))
|
|
+OS_VER=5_15
|
|
+endif
|
|
+
|
|
ifeq ($(KVER), 3.4.0)
|
|
OS_VER=3_4
|
|
endif
|
|
@@ -136,7 +140,7 @@ ifeq ($(ARCH), arm)
|
|
endif
|
|
|
|
ifeq ($(ARCH), arm64)
|
|
- ifeq ($(KVER),$(filter 4.1% 4.4% 4.9% 5.4% 5.10%,$(KVER)))
|
|
+ ifeq ($(KVER),$(filter 4.1% 4.4% 4.9% 5.4% 5.10% 5.15%,$(KVER)))
|
|
CPU_CFLAG= -DMODULE -Os -pipe -march=armv8-a -mcpu=cortex-a53+crypto -fno-caller-saves -fno-strict-aliasing -Werror -fno-common -Wno-format-security -Wno-pointer-sign -Wno-unused-but-set-variable -Wno-error=unused-result -mcmodel=large
|
|
endif
|
|
endif
|
|
--- a/make/linux_opt.mk
|
|
+++ b/make/linux_opt.mk
|
|
@@ -437,7 +437,7 @@ ifeq (KSLIB, $(MODULE_TYPE))
|
|
KASAN_SHADOW_SCALE_SHIFT := 3
|
|
endif
|
|
|
|
- ifeq ($(OS_VER),$(filter 5_4 5_10, $(OS_VER)))
|
|
+ ifeq ($(OS_VER),$(filter 5_4 5_10 5_15, $(OS_VER)))
|
|
ifeq ($(ARCH), arm64)
|
|
KASAN_OPTION += -DKASAN_SHADOW_SCALE_SHIFT=$(KASAN_SHADOW_SCALE_SHIFT)
|
|
endif
|
|
@@ -468,7 +468,7 @@ ifeq (KSLIB, $(MODULE_TYPE))
|
|
|
|
endif
|
|
|
|
- ifeq ($(OS_VER),$(filter 4_4 5_4 5_10, $(OS_VER)))
|
|
+ ifeq ($(OS_VER),$(filter 4_4 5_4 5_10 5_15, $(OS_VER)))
|
|
MODULE_CFLAG += -DKVER34
|
|
MODULE_CFLAG += -DKVER32
|
|
MODULE_CFLAG += -DLNX26_22
|