mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-22 23:12:32 +00:00
5b66dfaf6c
Signed-off-by: Felix Fietkau <nbd@nbd.name>
21 lines
495 B
Diff
21 lines
495 B
Diff
--- a/hostapd/Makefile
|
|
+++ b/hostapd/Makefile
|
|
@@ -323,6 +323,7 @@ ifdef CONFIG_FILS
|
|
CFLAGS += -DCONFIG_FILS
|
|
OBJS += ../src/ap/fils_hlp.o
|
|
NEED_SHA384=y
|
|
+NEED_HMAC_SHA384_KDF=y
|
|
NEED_AES_SIV=y
|
|
ifdef CONFIG_FILS_SK_PFS
|
|
CFLAGS += -DCONFIG_FILS_SK_PFS
|
|
--- a/wpa_supplicant/Makefile
|
|
+++ b/wpa_supplicant/Makefile
|
|
@@ -309,6 +309,7 @@ endif
|
|
ifdef CONFIG_FILS
|
|
CFLAGS += -DCONFIG_FILS
|
|
NEED_SHA384=y
|
|
+NEED_HMAC_SHA384_KDF=y
|
|
NEED_AES_SIV=y
|
|
ifdef CONFIG_FILS_SK_PFS
|
|
CFLAGS += -DCONFIG_FILS_SK_PFS
|