mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-20 14:13:16 +00:00
de79a0a9e0
Remove "001-neon-implementation-of-adler32.patch" because upstreamed
deleted assembler code optimizations:
d0704a8201
Remove upstreamed patches:
- 006-fix-CVE-2022-37434.patch
- 007-fix-null-dereference-in-fix-CVE-2022-37434.patch
Refresh patches:
- 002-arm-specific-optimisations-for-inflate.patch
- 003-arm-specific-optimisations-for-inflate.patch
- 004-attach-sourcefiles-in-patch-002-to-buildsystem.patch
Switch to "https github.com" for downloading source files.
Release Announcements:
https://github.com/madler/zlib/releases/tag/v1.2.13
Signed-off-by: Nick Hainke <vincent@systemli.org>
99 lines
1.3 KiB
Diff
99 lines
1.3 KiB
Diff
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -91,34 +91,67 @@ set(ZLIB_PUBLIC_HDRS
|
|
${CMAKE_CURRENT_BINARY_DIR}/zconf.h
|
|
zlib.h
|
|
)
|
|
-set(ZLIB_PRIVATE_HDRS
|
|
- crc32.h
|
|
- deflate.h
|
|
- gzguts.h
|
|
- inffast.h
|
|
- inffixed.h
|
|
- inflate.h
|
|
- inftrees.h
|
|
- trees.h
|
|
- zutil.h
|
|
-)
|
|
-set(ZLIB_SRCS
|
|
- adler32.c
|
|
- compress.c
|
|
- crc32.c
|
|
- deflate.c
|
|
- gzclose.c
|
|
- gzlib.c
|
|
- gzread.c
|
|
- gzwrite.c
|
|
- inflate.c
|
|
- infback.c
|
|
- inftrees.c
|
|
- inffast.c
|
|
- trees.c
|
|
- uncompr.c
|
|
- zutil.c
|
|
-)
|
|
+
|
|
+if(ARMv8)
|
|
+ set(ZLIB_PRIVATE_HDRS
|
|
+ crc32.h
|
|
+ deflate.h
|
|
+ gzguts.h
|
|
+ inffast.h
|
|
+ inffixed.h
|
|
+ inflate.h
|
|
+ inftrees.h
|
|
+ trees.h
|
|
+ zutil.h
|
|
+ contrib/arm/chunkcopy.h
|
|
+ )
|
|
+ set(ZLIB_SRCS
|
|
+ adler32.c
|
|
+ compress.c
|
|
+ crc32.c
|
|
+ deflate.c
|
|
+ gzclose.c
|
|
+ gzlib.c
|
|
+ gzread.c
|
|
+ gzwrite.c
|
|
+ infback.c
|
|
+ inftrees.c
|
|
+ contrib/arm/inflate.c
|
|
+ contrib/arm/inffast.c
|
|
+ trees.c
|
|
+ uncompr.c
|
|
+ zutil.c
|
|
+ )
|
|
+ else()
|
|
+ set(ZLIB_PRIVATE_HDRS
|
|
+ crc32.h
|
|
+ deflate.h
|
|
+ gzguts.h
|
|
+ inffast.h
|
|
+ inffixed.h
|
|
+ inflate.h
|
|
+ inftrees.h
|
|
+ trees.h
|
|
+ zutil.h
|
|
+ )
|
|
+ set(ZLIB_SRCS
|
|
+ adler32.c
|
|
+ compress.c
|
|
+ crc32.c
|
|
+ deflate.c
|
|
+ gzclose.c
|
|
+ gzlib.c
|
|
+ gzread.c
|
|
+ gzwrite.c
|
|
+ inflate.c
|
|
+ infback.c
|
|
+ inftrees.c
|
|
+ inffast.c
|
|
+ trees.c
|
|
+ uncompr.c
|
|
+ zutil.c
|
|
+ )
|
|
+endif()
|
|
|
|
if(NOT MINGW)
|
|
set(ZLIB_DLL_SRCS
|