mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-22 15:02:32 +00:00
7a7b2fd809
This adds the latest version of ofpart commit. It hopefully 1. Doesn't break compilation 2. Doesn't break partitioning (this time). It's required to implement fixed partitioning with some quirks. It's required by bcm53xx, bcm4908, kirkwood, lantiq and mvebu. Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
28 lines
1.1 KiB
Diff
28 lines
1.1 KiB
Diff
--- a/drivers/mtd/parsers/Makefile
|
|
+++ b/drivers/mtd/parsers/Makefile
|
|
@@ -7,6 +7,7 @@ obj-$(CONFIG_MTD_MYLOADER_PARTS) += myl
|
|
obj-$(CONFIG_MTD_OF_PARTS) += ofpart.o
|
|
ofpart-y += ofpart_core.o
|
|
ofpart-$(CONFIG_MTD_OF_PARTS_BCM4908) += ofpart_bcm4908.o
|
|
+obj-$(CONFIG_MTD_PARSER_CYBERTAN) += parser_cybertan.o
|
|
obj-$(CONFIG_MTD_PARSER_IMAGETAG) += parser_imagetag.o
|
|
obj-$(CONFIG_MTD_AFS_PARTS) += afs.o
|
|
obj-$(CONFIG_MTD_PARSER_TRX) += parser_trx.o
|
|
--- a/drivers/mtd/parsers/Kconfig
|
|
+++ b/drivers/mtd/parsers/Kconfig
|
|
@@ -92,6 +92,14 @@ config MTD_OF_PARTS_BCM4908
|
|
that can have multiple "firmware" partitions. It takes care of
|
|
finding currently used one and backup ones.
|
|
|
|
+config MTD_PARSER_CYBERTAN
|
|
+ tristate "Parser for Cybertan format partitions"
|
|
+ depends on MTD && (ATH79 || COMPILE_TEST)
|
|
+ help
|
|
+ Cybertan has a proprietory header than encompasses a Broadcom trx
|
|
+ header. This driver will parse the header and take care of the
|
|
+ special offsets that result in the extra headers.
|
|
+
|
|
config MTD_PARSER_IMAGETAG
|
|
tristate "Parser for BCM963XX Image Tag format partitions"
|
|
depends on BCM63XX || BMIPS_GENERIC || COMPILE_TEST
|