mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-22 06:57:57 +00:00
95f089dafe
This patch refresh all patches in patches-5.10/ to adjust for Kernel 5.10. Signed-off-by: INAGAKI Hiroshi <musashino.open@gmail.com>
29 lines
893 B
Diff
29 lines
893 B
Diff
--- a/drivers/clocksource/Kconfig
|
|
+++ b/drivers/clocksource/Kconfig
|
|
@@ -126,6 +126,15 @@ config RDA_TIMER
|
|
help
|
|
Enables the support for the RDA Micro timer driver.
|
|
|
|
+config RTL9300_TIMER
|
|
+ bool "Clocksource/timer for the Realtek RTL9300 family of SoCs"
|
|
+ depends on MIPS
|
|
+ select COMMON_CLK
|
|
+ select TIMER_OF
|
|
+ select CLKSRC_MMIO
|
|
+ help
|
|
+ Enables support for the Realtek RTL9300 timer driver.
|
|
+
|
|
config SUN4I_TIMER
|
|
bool "Sun4i timer driver" if COMPILE_TEST
|
|
depends on HAS_IOMEM
|
|
--- a/drivers/clocksource/Makefile
|
|
+++ b/drivers/clocksource/Makefile
|
|
@@ -63,6 +63,7 @@ obj-$(CONFIG_MILBEAUT_TIMER) += timer-mi
|
|
obj-$(CONFIG_SPRD_TIMER) += timer-sprd.o
|
|
obj-$(CONFIG_NPCM7XX_TIMER) += timer-npcm7xx.o
|
|
obj-$(CONFIG_RDA_TIMER) += timer-rda.o
|
|
+obj-$(CONFIG_RTL9300_TIMER) += timer-rtl9300.o
|
|
|
|
obj-$(CONFIG_ARC_TIMERS) += arc_timer.o
|
|
obj-$(CONFIG_ARM_ARCH_TIMER) += arm_arch_timer.o
|