mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-20 14:13:16 +00:00
dc416983bb
All necessary blobs are now contained in the upstream repository, no more wild replacing of blobs needed. This new version also contains new storage drivers for (SPI-)NAND which already comes with support for FM35Q1GA, so that patch can be dropped as well. Tested on: * Bananapi BPi-R64 - sdmmc-2ddr - emmc-2ddr * Linksys E8450 - snand-1ddr All works fine (booting Bananapi BPi-R64 from SD Card does NOT require a signed image, so patch arm-trusted-firmware-mediatek to allow doing that). Signed-off-by: Daniel Golle <daniel@makrotopia.org>
18 lines
816 B
Diff
18 lines
816 B
Diff
Index: arm-trusted-firmware-mediatek-2021-02-25-1220acb0/plat/mediatek/mt7622/platform.mk
|
|
===================================================================
|
|
--- arm-trusted-firmware-mediatek-2021-02-25-1220acb0.orig/plat/mediatek/mt7622/platform.mk
|
|
+++ arm-trusted-firmware-mediatek-2021-02-25-1220acb0/plat/mediatek/mt7622/platform.mk
|
|
@@ -99,9 +99,9 @@ BL2_SOURCES += drivers/mmc/mmc.c \
|
|
BROM_HEADER_TYPE := sdmmc
|
|
CPPFLAGS += -DMSDC_INDEX=1
|
|
DEVICE_HEADER_OFFSET ?= 0x80000
|
|
-ifeq ($(BROM_SIGN_KEY),)
|
|
-$(error BootROM signing key is required for SD booting. Please specify BROM_SIGN_KEY)
|
|
-endif
|
|
+#ifeq ($(BROM_SIGN_KEY),)
|
|
+#$(error BootROM signing key is required for SD booting. Please specify BROM_SIGN_KEY)
|
|
+#endif
|
|
endif
|
|
ifeq ($(BOOT_DEVICE),snand)
|
|
include ${MTK_PLAT}/common/drivers/snfi/mtk-snand.mk
|