mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-21 14:37:57 +00:00
8299d1f057
Rebased RPi foundation patches on linux 5.10.59, removed applied and reverted patches, wireless patches and defconfig patches. bcm2708: boot tested on RPi B+ v1.2 bcm2709: boot tested on RPi 4B v1.1 4G bcm2711: boot tested on RPi 4B v1.1 4G Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
217 lines
6.2 KiB
Diff
217 lines
6.2 KiB
Diff
From 5752746d0694ee607c2971735f2befc8a86fbab9 Mon Sep 17 00:00:00 2001
|
|
From: Dave Stevenson <dave.stevenson@raspberrypi.com>
|
|
Date: Thu, 15 Apr 2021 16:46:34 +0100
|
|
Subject: [PATCH] dtoverlays: Add overlays for JDI LT070ME05000
|
|
1200x1920 DSI panel
|
|
|
|
Credit to forum member gizmomouse on
|
|
https://www.raspberrypi.org/forums/viewtopic.php?f=98&t=253912 and
|
|
Andrey Vostrukhin of Harlab for these overlays.
|
|
|
|
See https://github.com/harlab/CM4_LCD_LT070ME05000 for
|
|
schematics and docs for the adapter board to connect this panel which
|
|
is found in the Asus/Google 2013 Nexus 7" tablet and therefore
|
|
relatively easily available.
|
|
|
|
Note that this uses 4 DSI data lanes, and therefore MUST be used
|
|
with DISP1 on a Compute Module. It can not be used on a standard
|
|
Pi.
|
|
|
|
There are two versions of the adapter board. V1 connects the
|
|
display controls to Pi GPIOs, whilst v2 uses an I2C GPIO expander
|
|
so needs no additional connections beyond the FFC and power.
|
|
|
|
The touchscreen overlay for these panels varies, so that part
|
|
is not configured.
|
|
|
|
Signed-off-by: Dave Stevenson <dave.stevenson@raspberrypi.com>
|
|
---
|
|
arch/arm/boot/dts/overlays/Makefile | 2 +
|
|
arch/arm/boot/dts/overlays/README | 21 ++++++
|
|
.../vc4-kms-dsi-lt070me05000-overlay.dts | 69 +++++++++++++++++++
|
|
.../vc4-kms-dsi-lt070me05000-v2-overlay.dts | 64 +++++++++++++++++
|
|
4 files changed, 156 insertions(+)
|
|
create mode 100644 arch/arm/boot/dts/overlays/vc4-kms-dsi-lt070me05000-overlay.dts
|
|
create mode 100644 arch/arm/boot/dts/overlays/vc4-kms-dsi-lt070me05000-v2-overlay.dts
|
|
|
|
--- a/arch/arm/boot/dts/overlays/Makefile
|
|
+++ b/arch/arm/boot/dts/overlays/Makefile
|
|
@@ -213,6 +213,8 @@ dtbo-$(CONFIG_ARCH_BCM2835) += \
|
|
upstream-pi4.dtbo \
|
|
vc4-fkms-v3d.dtbo \
|
|
vc4-kms-dsi-7inch.dtbo \
|
|
+ vc4-kms-dsi-lt070me05000.dtbo \
|
|
+ vc4-kms-dsi-lt070me05000-v2.dtbo \
|
|
vc4-kms-kippah-7inch.dtbo \
|
|
vc4-kms-v3d.dtbo \
|
|
vc4-kms-v3d-pi4.dtbo \
|
|
--- a/arch/arm/boot/dts/overlays/README
|
|
+++ b/arch/arm/boot/dts/overlays/README
|
|
@@ -3158,6 +3158,27 @@ Load: dtoverlay=vc4-kms-dsi-7inch
|
|
Params: <None>
|
|
|
|
|
|
+Name: vc4-kms-dsi-lt070me05000
|
|
+Info: Enable a JDI LT070ME05000 DSI display on DSI1.
|
|
+ Note that this is a 4 lane DSI device, so it will only work on a Compute
|
|
+ Module.
|
|
+ Requires vc4-kms-v3d to be loaded.
|
|
+Load: dtoverlay=vc4-kms-dsi-lt070me05000,<param>
|
|
+Params: reset GPIO for the reset signal (default 17)
|
|
+ enable GPIO for the enable signal (default 4)
|
|
+ dcdc-en GPIO for the DC-DC converter enable (default 5)
|
|
+
|
|
+
|
|
+Name: vc4-kms-dsi-lt070me05000-v2
|
|
+Info: Enable a JDI LT070ME05000 DSI display on DSI1 using Harlab's V2
|
|
+ interface board.
|
|
+ Note that this is a 4 lane DSI device, so it will only work on a Compute
|
|
+ Module.
|
|
+ Requires vc4-kms-v3d to be loaded.
|
|
+Load: dtoverlay=vc4-kms-dsi-lt070me05000-v2
|
|
+Params: <None>
|
|
+
|
|
+
|
|
Name: vc4-kms-kippah-7inch
|
|
Info: Enable the Adafruit DPI Kippah with the 7" Ontat panel attached.
|
|
Requires vc4-kms-v3d to be loaded.
|
|
--- /dev/null
|
|
+++ b/arch/arm/boot/dts/overlays/vc4-kms-dsi-lt070me05000-overlay.dts
|
|
@@ -0,0 +1,69 @@
|
|
+/*
|
|
+ * Device Tree overlay to connect a JDI LT070ME05000 DSI panel to DSI1.
|
|
+ * This uses 4 DSI data lanes, so can only be used with a Compute Module.
|
|
+ *
|
|
+ * Credit to forum user gizmomouse on
|
|
+ * https://www.raspberrypi.org/forums/viewtopic.php?f=98&t=253912 and
|
|
+ * Andrey Vostrukhin of Harlab for the overlay.
|
|
+ *
|
|
+ * Refer to https://github.com/harlab/CM4_LCD_LT070ME05000 for schematics and
|
|
+ * other documentation.
|
|
+ */
|
|
+
|
|
+/dts-v1/;
|
|
+/plugin/;
|
|
+
|
|
+/ {
|
|
+ compatible = "brcm,bcm2835";
|
|
+
|
|
+ fragment@0 {
|
|
+ target = <&dsi1>;
|
|
+ __overlay__{
|
|
+ status = "okay";
|
|
+ #address-cells = <1>;
|
|
+ #size-cells = <0>;
|
|
+ port {
|
|
+ dsi_out_port:endpoint {
|
|
+ remote-endpoint = <&panel_dsi_port>;
|
|
+ };
|
|
+ };
|
|
+
|
|
+ lt070me05000:lt070me05000@0 {
|
|
+ compatible = "jdi,lt070me05000";
|
|
+ status = "okay";
|
|
+ reg = <0>;
|
|
+ reset-gpios = <&gpio 17 1>; // LCD RST
|
|
+ enable-gpios = <&gpio 4 0>; // LCD Enable
|
|
+ dcdc-en-gpios = <&gpio 5 0>; // LCD DC-DC Enable
|
|
+ port {
|
|
+ panel_dsi_port: endpoint {
|
|
+ remote-endpoint = <&dsi_out_port>;
|
|
+ };
|
|
+ };
|
|
+ };
|
|
+ };
|
|
+ };
|
|
+
|
|
+ fragment@1 {
|
|
+ target = <&gpio>;
|
|
+ __overlay__ {
|
|
+ lt070me05000_pins: lt070me05000_pins {
|
|
+ brcm,pins = <4 5 17>;
|
|
+ brcm,function = <1 1 1>; // out
|
|
+ brcm,pull = <0 0 0>; // off
|
|
+ };
|
|
+ };
|
|
+
|
|
+ };
|
|
+
|
|
+ __overrides__ {
|
|
+ reset = <<070me05000_pins>,"brcm,pins:8",
|
|
+ <<070me05000>,"reset-gpios:4";
|
|
+
|
|
+ enable = <<070me05000_pins>,"brcm,pins:0",
|
|
+ <<070me05000>,"enable-gpios:4";
|
|
+
|
|
+ dcdc-en = <<070me05000_pins>,"brcm,pins:4",
|
|
+ <<070me05000>,"dcdc-en-gpios:4";
|
|
+ };
|
|
+};
|
|
--- /dev/null
|
|
+++ b/arch/arm/boot/dts/overlays/vc4-kms-dsi-lt070me05000-v2-overlay.dts
|
|
@@ -0,0 +1,64 @@
|
|
+/*
|
|
+ * Device Tree overlay to connect a JDI LT070ME05000 DSI panel to DSI1.
|
|
+ * This uses 4 DSI data lanes, so can only be used with a Compute Module.
|
|
+ *
|
|
+ * The overlay is for V2 of Harlab's interface board that uses a PCA9536 to
|
|
+ * handle the panel's control GPIOs instead of wiring it back to Pi GPIOs.
|
|
+ *
|
|
+ * Credit to Andrey Vostrukhin of Harlab for the overlay.
|
|
+ *
|
|
+ * Refer to https://github.com/harlab/CM4_LCD_LT070ME05000 for schematics and
|
|
+ * other documentation.
|
|
+ */
|
|
+
|
|
+/dts-v1/;
|
|
+/plugin/;
|
|
+
|
|
+/ {
|
|
+ compatible = "brcm,bcm2835";
|
|
+
|
|
+ fragment@0 {
|
|
+ target = <&i2c_csi_dsi>;
|
|
+ __overlay__ {
|
|
+ #address-cells = <1>;
|
|
+ #size-cells = <0>;
|
|
+ status = "okay";
|
|
+
|
|
+ pca: pca@41 {
|
|
+ compatible = "nxp,pca9536";
|
|
+ reg = <0x41>;
|
|
+ gpio-controller;
|
|
+ #gpio-cells = <2>;
|
|
+ status = "okay";
|
|
+ };
|
|
+ };
|
|
+ };
|
|
+
|
|
+ fragment@1 {
|
|
+ target = <&dsi1>;
|
|
+ __overlay__{
|
|
+ status = "okay";
|
|
+ #address-cells = <1>;
|
|
+ #size-cells = <0>;
|
|
+ port {
|
|
+ dsi_out_port:endpoint {
|
|
+ remote-endpoint = <&panel_dsi_port>;
|
|
+ };
|
|
+ };
|
|
+
|
|
+ lt070me05000:lt070me05000@0 {
|
|
+ compatible = "jdi,lt070me05000";
|
|
+ status = "okay";
|
|
+ reg = <0>;
|
|
+ reset-gpios = <&pca 0 1>;
|
|
+ enable-gpios = <&pca 2 0>;
|
|
+ dcdc-en-gpios = <&pca 1 0>;
|
|
+ port {
|
|
+ panel_dsi_port: endpoint {
|
|
+ remote-endpoint = <&dsi_out_port>;
|
|
+ };
|
|
+ };
|
|
+ };
|
|
+ };
|
|
+ };
|
|
+};
|