mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-21 14:37:57 +00:00
8299d1f057
Rebased RPi foundation patches on linux 5.10.59, removed applied and reverted patches, wireless patches and defconfig patches. bcm2708: boot tested on RPi B+ v1.2 bcm2709: boot tested on RPi 4B v1.1 4G bcm2711: boot tested on RPi 4B v1.1 4G Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
31 lines
893 B
Diff
31 lines
893 B
Diff
From a0dab30b7061e7b56a5bd74f03bafb8e97d52135 Mon Sep 17 00:00:00 2001
|
|
From: popcornmix <popcornmix@gmail.com>
|
|
Date: Mon, 28 Sep 2020 20:23:30 +0100
|
|
Subject: [PATCH] char: Add broadcom char drivers back to build files
|
|
|
|
See: https://github.com/raspberrypi/linux/issues/3875
|
|
Signed-off-by: popcornmix <popcornmix@gmail.com>
|
|
---
|
|
drivers/char/Kconfig | 2 ++
|
|
drivers/char/Makefile | 1 +
|
|
2 files changed, 3 insertions(+)
|
|
|
|
--- a/drivers/char/Kconfig
|
|
+++ b/drivers/char/Kconfig
|
|
@@ -5,6 +5,8 @@
|
|
|
|
menu "Character devices"
|
|
|
|
+source "drivers/char/broadcom/Kconfig"
|
|
+
|
|
source "drivers/tty/Kconfig"
|
|
|
|
config TTY_PRINTK
|
|
--- a/drivers/char/Makefile
|
|
+++ b/drivers/char/Makefile
|
|
@@ -47,3 +47,4 @@ obj-$(CONFIG_PS3_FLASH) += ps3flash.o
|
|
obj-$(CONFIG_XILLYBUS) += xillybus/
|
|
obj-$(CONFIG_POWERNV_OP_PANEL) += powernv-op-panel.o
|
|
obj-$(CONFIG_ADI) += adi.o
|
|
+obj-$(CONFIG_BRCM_CHAR_DRIVERS) += broadcom/
|