mirror of
https://github.com/openwrt/openwrt.git
synced 2025-01-15 01:10:29 +00:00
364a9be338
Release notes: https://lore.kernel.org/netdev/20221219225600.r54vejiqapn266cm@lion.mk-sys.cz/T/ Add patches fixing compilation: - 100-uapi-Bring-in-if-h.patch - 101-netlink-Fix-maybe-uninitialized-meters-variable.patch - 102-raw-marvell-c-Fix-build-with-musl-libc.patch Signed-off-by: Nick Hainke <vincent@systemli.org>
64 lines
1.8 KiB
Diff
64 lines
1.8 KiB
Diff
From: Florian Fainelli <f.fainelli@gmail.com>
|
|
To: netdev@vger.kernel.org
|
|
Subject: [PATCH ethtool v2 3/3] marvell.c: Fix build with musl-libc
|
|
Date: Sat, 14 Jan 2023 08:34:11 -0800
|
|
|
|
After commit 1fa60003a8b8 ("misc: header includes cleanup") we stopped
|
|
including net/if.h which resolved the proper defines to pull in
|
|
sys/types.h and provide a definition for u_int32_t. With musl-libc we
|
|
would need to define _GNU_SOURCE to ensure that sys/types.h does provide a
|
|
definition for u_int32_t.
|
|
|
|
Rather, just replace u_uint{16,32}_t with the more standard
|
|
uint{16,32}_t types from stdint.h
|
|
|
|
Fixes: 1fa60003a8b8 ("misc: header includes cleanup")
|
|
Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
|
|
---
|
|
marvell.c | 34 +++++++++++++++++-----------------
|
|
1 file changed, 17 insertions(+), 17 deletions(-)
|
|
|
|
--- a/marvell.c
|
|
+++ b/marvell.c
|
|
@@ -31,23 +31,23 @@ static void dump_timer(const char *name,
|
|
static void dump_queue(const char *name, const void *a, int rx)
|
|
{
|
|
struct desc {
|
|
- u_int32_t ctl;
|
|
- u_int32_t next;
|
|
- u_int32_t data_lo;
|
|
- u_int32_t data_hi;
|
|
- u_int32_t status;
|
|
- u_int32_t timestamp;
|
|
- u_int16_t csum2;
|
|
- u_int16_t csum1;
|
|
- u_int16_t csum2_start;
|
|
- u_int16_t csum1_start;
|
|
- u_int32_t addr_lo;
|
|
- u_int32_t addr_hi;
|
|
- u_int32_t count_lo;
|
|
- u_int32_t count_hi;
|
|
- u_int32_t byte_count;
|
|
- u_int32_t csr;
|
|
- u_int32_t flag;
|
|
+ uint32_t ctl;
|
|
+ uint32_t next;
|
|
+ uint32_t data_lo;
|
|
+ uint32_t data_hi;
|
|
+ uint32_t status;
|
|
+ uint32_t timestamp;
|
|
+ uint16_t csum2;
|
|
+ uint16_t csum1;
|
|
+ uint16_t csum2_start;
|
|
+ uint16_t csum1_start;
|
|
+ uint32_t addr_lo;
|
|
+ uint32_t addr_hi;
|
|
+ uint32_t count_lo;
|
|
+ uint32_t count_hi;
|
|
+ uint32_t byte_count;
|
|
+ uint32_t csr;
|
|
+ uint32_t flag;
|
|
};
|
|
const struct desc *d = a;
|
|
|