mirror of
https://github.com/openwrt/openwrt.git
synced 2025-01-10 15:03:07 +00:00
4f277b4da5
A lot of patches are outdated versions of upstreamed patches and drivers. So lets pull in the upstreamed patches and reorder remaining ones. This drops the unnecessary 721-dts-ipq4019-add-ethernet-essedma-node.patch which adds nodes for not yet in OpenWrt IPQESS driver. Signed-off-by: Robert Marko <robert.marko@sartura.hr> [do not touch 902-dts-ipq4019-ap-dk04.1.patch here] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
27 lines
780 B
Diff
27 lines
780 B
Diff
--- a/drivers/net/phy/Kconfig
|
|
+++ b/drivers/net/phy/Kconfig
|
|
@@ -588,6 +588,13 @@ config MDIO_IPQ40XX
|
|
This driver supports the MDIO interface found in Qualcomm
|
|
Atheros ipq40xx Soc chip.
|
|
|
|
+config AR40XX_PHY
|
|
+ tristate "Driver for Qualcomm Atheros IPQ40XX switches"
|
|
+ depends on HAS_IOMEM && OF
|
|
+ select SWCONFIG
|
|
+ help
|
|
+ This is the driver for Qualcomm Atheros IPQ40XX ESS switches.
|
|
+
|
|
endif # PHYLIB
|
|
|
|
config MICREL_KS8995MA
|
|
--- a/drivers/net/phy/Makefile
|
|
+++ b/drivers/net/phy/Makefile
|
|
@@ -70,6 +70,7 @@ ifdef CONFIG_HWMON
|
|
aquantia-objs += aquantia_hwmon.o
|
|
endif
|
|
obj-$(CONFIG_AQUANTIA_PHY) += aquantia.o
|
|
+obj-$(CONFIG_AR40XX_PHY) += ar40xx.o
|
|
obj-$(CONFIG_AX88796B_PHY) += ax88796b.o
|
|
obj-$(CONFIG_AT803X_PHY) += at803x.o
|
|
obj-$(CONFIG_BCM63XX_PHY) += bcm63xx.o
|