mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-22 15:02:32 +00:00
3c3614cec4
When using alpine as host, things start to fail. Lets pull in the upstream alpine patches to make things work. This should not affect other hosts. Note, that Alpine has the '_GNU_SOURCE' define in the APKBUILD file, but here we add this flag to the needed fix flags patch, which does similar things too. Signed-off-by: Olliver Schinagl <oliver@schinagl.nl>
60 lines
1.2 KiB
Diff
60 lines
1.2 KiB
Diff
--- a/C/CpuArch.c
|
|
+++ b/C/CpuArch.c
|
|
@@ -421,8 +421,6 @@ BoolInt CPU_IsSupported_AES (void) { ret
|
|
|
|
#ifdef USE_HWCAP
|
|
|
|
-#include <asm/hwcap.h>
|
|
-
|
|
#define MY_HWCAP_CHECK_FUNC_2(name1, name2) \
|
|
BoolInt CPU_IsSupported_ ## name1() { return (getauxval(AT_HWCAP) & (HWCAP_ ## name2)) ? 1 : 0; }
|
|
|
|
--- a/C/Threads.c
|
|
+++ b/C/Threads.c
|
|
@@ -257,7 +257,7 @@ WRes Thread_Create_With_CpuSet(CThread *
|
|
*/
|
|
|
|
// ret2 =
|
|
- pthread_attr_setaffinity_np(&attr, sizeof(*cpuSet), cpuSet);
|
|
+ //pthread_attr_setaffinity_np(&attr, sizeof(*cpuSet), cpuSet);
|
|
// if (ret2) ret = ret2;
|
|
#endif
|
|
}
|
|
@@ -267,14 +267,12 @@ WRes Thread_Create_With_CpuSet(CThread *
|
|
if (!ret)
|
|
{
|
|
p->_created = 1;
|
|
- /*
|
|
if (cpuSet)
|
|
{
|
|
// ret2 =
|
|
pthread_setaffinity_np(p->_tid, sizeof(*cpuSet), cpuSet);
|
|
// if (ret2) ret = ret2;
|
|
}
|
|
- */
|
|
}
|
|
}
|
|
// ret2 =
|
|
--- a/C/Threads.h
|
|
+++ b/C/Threads.h
|
|
@@ -19,6 +19,7 @@
|
|
#endif
|
|
|
|
#include <pthread.h>
|
|
+#include <sched.h>
|
|
|
|
#endif
|
|
|
|
--- a/CPP/Windows/SystemInfo.cpp
|
|
+++ b/CPP/Windows/SystemInfo.cpp
|
|
@@ -36,9 +36,6 @@
|
|
#endif
|
|
*/
|
|
|
|
-#ifdef MY_CPU_ARM_OR_ARM64
|
|
-#include <asm/hwcap.h>
|
|
-#endif
|
|
#endif
|
|
|
|
#ifdef __linux__
|