openwrt/target/linux/brcm2708/patches-4.19/950-0297-arm64-dts-broadcom-Enable-fixups-for-overlays.patch
Álvaro Fernández Rojas 4295485719 brcm2708: add linux 4.19 support
Boot tested on Raspberry Pi B+ (BCM2708) and Raspberry Pi 2 (BCM2709)

Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
2019-07-14 12:44:14 +02:00

24 lines
726 B
Diff

From e09f9e3d46d8a393d54e414a718d232d13169a29 Mon Sep 17 00:00:00 2001
From: Phil Elwell <phil@raspberrypi.org>
Date: Tue, 15 Jan 2019 09:56:41 +0000
Subject: [PATCH 297/703] arm64: dts: broadcom: Enable fixups for overlays
See: https://github.com/raspberrypi/linux/pull/2733
Signed-off-by: Phil Elwell <phil@raspberrypi.org>
---
arch/arm64/boot/dts/broadcom/Makefile | 5 +++++
1 file changed, 5 insertions(+)
--- a/arch/arm64/boot/dts/broadcom/Makefile
+++ b/arch/arm64/boot/dts/broadcom/Makefile
@@ -9,3 +9,8 @@ dtb-$(CONFIG_ARCH_BCM2835) += bcm2710-rp
subdir-y += northstar2
subdir-y += stingray
+
+# Enable fixups to support overlays on BCM2835 platforms
+ifeq ($(CONFIG_ARCH_BCM2835),y)
+ DTC_FLAGS ?= -@
+endif