mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-26 00:41:17 +00:00
4295485719
Boot tested on Raspberry Pi B+ (BCM2708) and Raspberry Pi 2 (BCM2709) Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
26 lines
681 B
Diff
26 lines
681 B
Diff
From ab40577b4601c0eeeedb5c3688cf0719b2bc582e Mon Sep 17 00:00:00 2001
|
|
From: Khem Raj <raj.khem@gmail.com>
|
|
Date: Fri, 10 Feb 2017 17:57:08 -0800
|
|
Subject: [PATCH 101/703] build/arm64: Add rules for .dtbo files for dts
|
|
overlays
|
|
|
|
We now create overlays as .dtbo files.
|
|
|
|
Signed-off-by: Khem Raj <raj.khem@gmail.com>
|
|
---
|
|
arch/arm64/Makefile | 3 +++
|
|
1 file changed, 3 insertions(+)
|
|
|
|
--- a/arch/arm64/Makefile
|
|
+++ b/arch/arm64/Makefile
|
|
@@ -131,6 +131,9 @@ zinstall install:
|
|
%.dtb: scripts
|
|
$(Q)$(MAKE) $(build)=$(boot)/dts $(boot)/dts/$@
|
|
|
|
+%.dtbo: | scripts
|
|
+ $(Q)$(MAKE) $(build)=$(boot)/dts MACHINE=$(MACHINE) $(boot)/dts/$@
|
|
+
|
|
PHONY += dtbs dtbs_install
|
|
|
|
dtbs: prepare scripts
|