mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-29 18:19:02 +00:00
1447924c95
Updates mbedtls to 2.14.1. This builds on the previous master commit7849f74117
. Fixes in 2.13.0: * Fixed a security issue in the X.509 module which could lead to a buffer overread during certificate extensions parsing. * Several bugfixes. * Improvements for better support for DTLS on low-bandwidth, high latency networks with high packet loss. Fixes in 2.14.1: * CVE-2018-19608: Local timing attack on RSA decryption Includes master commit9e7c4702a1
'mbedtls: fix compilation on ARM < 6'. Signed-off-by: Daniel Engberg <daniel.engberg.lists@pyret.net> [Update to 2.14.1] Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> [Adapted and squashed for 18.06.1+] Signed-off-by: Stijn Segers <foss@volatilesystems.org> Acked-by: Hauke Mehrtens <hauke@hauke-m.de>
35 lines
1.2 KiB
Diff
35 lines
1.2 KiB
Diff
--- a/library/CMakeLists.txt
|
|
+++ b/library/CMakeLists.txt
|
|
@@ -159,7 +159,7 @@ endif(USE_STATIC_MBEDTLS_LIBRARY)
|
|
|
|
if(USE_SHARED_MBEDTLS_LIBRARY)
|
|
add_library(mbedcrypto SHARED ${src_crypto})
|
|
- set_target_properties(mbedcrypto PROPERTIES VERSION 2.14.1 SOVERSION 3)
|
|
+ set_target_properties(mbedcrypto PROPERTIES VERSION 2.12.0 SOVERSION 1)
|
|
target_link_libraries(mbedcrypto ${libs})
|
|
|
|
add_library(mbedx509 SHARED ${src_x509})
|
|
@@ -167,7 +167,7 @@ if(USE_SHARED_MBEDTLS_LIBRARY)
|
|
target_link_libraries(mbedx509 ${libs} mbedcrypto)
|
|
|
|
add_library(mbedtls SHARED ${src_tls})
|
|
- set_target_properties(mbedtls PROPERTIES VERSION 2.14.1 SOVERSION 12)
|
|
+ set_target_properties(mbedtls PROPERTIES VERSION 2.12.0 SOVERSION 10)
|
|
target_link_libraries(mbedtls ${libs} mbedx509)
|
|
|
|
install(TARGETS mbedtls mbedx509 mbedcrypto
|
|
--- a/library/Makefile
|
|
+++ b/library/Makefile
|
|
@@ -35,9 +35,9 @@ LOCAL_CFLAGS += -fPIC -fpic
|
|
endif
|
|
endif
|
|
|
|
-SOEXT_TLS=so.12
|
|
+SOEXT_TLS=so.10
|
|
SOEXT_X509=so.0
|
|
-SOEXT_CRYPTO=so.3
|
|
+SOEXT_CRYPTO=so.1
|
|
|
|
# Set AR_DASH= (empty string) to use an ar implentation that does not accept
|
|
# the - prefix for command line options (e.g. llvm-ar)
|