mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-20 06:08:08 +00:00
5053593e66
Reorder kernel patches after recent backports. Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
47 lines
1.6 KiB
Diff
47 lines
1.6 KiB
Diff
From 590b60fb08cb1e70fe02d3f407c6b3dbe9ad06ff Mon Sep 17 00:00:00 2001
|
|
From: =?UTF-8?q?=C3=81lvaro=20Fern=C3=A1ndez=20Rojas?= <noltari@gmail.com>
|
|
Date: Mon, 1 Mar 2021 07:34:39 +0100
|
|
Subject: [PATCH 3/4] net: broadcom: add BCM6368 enetsw controller driver
|
|
MIME-Version: 1.0
|
|
Content-Type: text/plain; charset=UTF-8
|
|
Content-Transfer-Encoding: 8bit
|
|
|
|
This controller is present on BCM6318, BCM6328, BCM6362, BCM6368 and BCM63268
|
|
SoCs.
|
|
|
|
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
|
|
---
|
|
drivers/net/ethernet/broadcom/Kconfig | 8 +
|
|
drivers/net/ethernet/broadcom/Makefile | 1 +
|
|
.../net/ethernet/broadcom/bcm6368-enetsw.c | 1111 +++++++++++++++++
|
|
3 files changed, 1120 insertions(+)
|
|
create mode 100644 drivers/net/ethernet/broadcom/bcm6368-enetsw.c
|
|
|
|
--- a/drivers/net/ethernet/broadcom/Kconfig
|
|
+++ b/drivers/net/ethernet/broadcom/Kconfig
|
|
@@ -60,6 +60,14 @@ config BCM63XX_ENET
|
|
This driver supports the ethernet MACs in the Broadcom 63xx
|
|
MIPS chipset family (BCM63XX).
|
|
|
|
+config BCM6368_ENETSW
|
|
+ tristate "Broadcom BCM6368 internal mac support"
|
|
+ depends on BMIPS_GENERIC || COMPILE_TEST
|
|
+ default y
|
|
+ help
|
|
+ This driver supports Ethernet controller integrated into Broadcom
|
|
+ BCM6368 family SoCs.
|
|
+
|
|
config BCMGENET
|
|
tristate "Broadcom GENET internal MAC support"
|
|
depends on HAS_IOMEM
|
|
--- a/drivers/net/ethernet/broadcom/Makefile
|
|
+++ b/drivers/net/ethernet/broadcom/Makefile
|
|
@@ -5,6 +5,7 @@
|
|
|
|
obj-$(CONFIG_B44) += b44.o
|
|
obj-$(CONFIG_BCM63XX_ENET) += bcm63xx_enet.o
|
|
+obj-$(CONFIG_BCM6368_ENETSW) += bcm6368-enetsw.o
|
|
obj-$(CONFIG_BCMGENET) += genet/
|
|
obj-$(CONFIG_BNX2) += bnx2.o
|
|
obj-$(CONFIG_CNIC) += cnic.o
|