mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-20 06:08:08 +00:00
ce014b1e39
All patches automatically rebased. Build system: x86_64 Build-tested: bcm2711/RPi4B, mt7622/RT3200 Run-tested: bcm2711/RPi4B, mt7622/RT3200 Signed-off-by: John Audia <therealgraysky@proton.me>
215 lines
7.2 KiB
Diff
215 lines
7.2 KiB
Diff
From 69357074558daf6ff24c9f58714935e9e095a865 Mon Sep 17 00:00:00 2001
|
|
From: OpenWrt community <openwrt-devel@lists.openwrt.org>
|
|
Date: Wed, 13 Jul 2022 13:37:33 +0200
|
|
Subject: [PATCH] kernel: add block fit partition parser
|
|
|
|
---
|
|
block/blk.h | 2 ++
|
|
block/partitions/Kconfig | 7 +++++++
|
|
block/partitions/Makefile | 1 +
|
|
block/partitions/check.h | 3 +++
|
|
block/partitions/core.c | 17 +++++++++++++++++
|
|
block/partitions/efi.c | 8 ++++++++
|
|
block/partitions/efi.h | 3 +++
|
|
block/partitions/msdos.c | 10 ++++++++++
|
|
drivers/mtd/mtd_blkdevs.c | 2 ++
|
|
drivers/mtd/ubi/block.c | 3 +++
|
|
include/linux/msdos_partition.h | 1 +
|
|
11 files changed, 57 insertions(+)
|
|
|
|
--- a/block/blk.h
|
|
+++ b/block/blk.h
|
|
@@ -354,6 +354,8 @@ void blk_free_ext_minor(unsigned int min
|
|
#define ADDPART_FLAG_NONE 0
|
|
#define ADDPART_FLAG_RAID 1
|
|
#define ADDPART_FLAG_WHOLEDISK 2
|
|
+#define ADDPART_FLAG_READONLY 4
|
|
+#define ADDPART_FLAG_ROOTDEV 8
|
|
int bdev_add_partition(struct gendisk *disk, int partno, sector_t start,
|
|
sector_t length);
|
|
int bdev_del_partition(struct gendisk *disk, int partno);
|
|
--- a/block/partitions/Kconfig
|
|
+++ b/block/partitions/Kconfig
|
|
@@ -101,6 +101,13 @@ config ATARI_PARTITION
|
|
Say Y here if you would like to use hard disks under Linux which
|
|
were partitioned under the Atari OS.
|
|
|
|
+config FIT_PARTITION
|
|
+ bool "Flattened-Image-Tree (FIT) partition support" if PARTITION_ADVANCED
|
|
+ default n
|
|
+ help
|
|
+ Say Y here if your system needs to mount the filesystem part of
|
|
+ a Flattened-Image-Tree (FIT) image commonly used with Das U-Boot.
|
|
+
|
|
config IBM_PARTITION
|
|
bool "IBM disk label and partition support"
|
|
depends on PARTITION_ADVANCED && S390
|
|
--- a/block/partitions/Makefile
|
|
+++ b/block/partitions/Makefile
|
|
@@ -8,6 +8,7 @@ obj-$(CONFIG_ACORN_PARTITION) += acorn.o
|
|
obj-$(CONFIG_AMIGA_PARTITION) += amiga.o
|
|
obj-$(CONFIG_ATARI_PARTITION) += atari.o
|
|
obj-$(CONFIG_AIX_PARTITION) += aix.o
|
|
+obj-$(CONFIG_FIT_PARTITION) += fit.o
|
|
obj-$(CONFIG_CMDLINE_PARTITION) += cmdline.o
|
|
obj-$(CONFIG_MAC_PARTITION) += mac.o
|
|
obj-$(CONFIG_LDM_PARTITION) += ldm.o
|
|
--- a/block/partitions/check.h
|
|
+++ b/block/partitions/check.h
|
|
@@ -58,6 +58,7 @@ int amiga_partition(struct parsed_partit
|
|
int atari_partition(struct parsed_partitions *state);
|
|
int cmdline_partition(struct parsed_partitions *state);
|
|
int efi_partition(struct parsed_partitions *state);
|
|
+int fit_partition(struct parsed_partitions *state);
|
|
int ibm_partition(struct parsed_partitions *);
|
|
int karma_partition(struct parsed_partitions *state);
|
|
int ldm_partition(struct parsed_partitions *state);
|
|
@@ -68,3 +69,5 @@ int sgi_partition(struct parsed_partitio
|
|
int sun_partition(struct parsed_partitions *state);
|
|
int sysv68_partition(struct parsed_partitions *state);
|
|
int ultrix_partition(struct parsed_partitions *state);
|
|
+
|
|
+int parse_fit_partitions(struct parsed_partitions *state, u64 start_sector, u64 nr_sectors, int *slot, int add_remain);
|
|
--- a/block/partitions/core.c
|
|
+++ b/block/partitions/core.c
|
|
@@ -12,6 +12,10 @@
|
|
#include <linux/vmalloc.h>
|
|
#include <linux/blktrace_api.h>
|
|
#include <linux/raid/detect.h>
|
|
+#ifdef CONFIG_FIT_PARTITION
|
|
+#include <linux/root_dev.h>
|
|
+#endif
|
|
+
|
|
#include "check.h"
|
|
|
|
static int (*check_part[])(struct parsed_partitions *) = {
|
|
@@ -48,6 +52,9 @@ static int (*check_part[])(struct parsed
|
|
#ifdef CONFIG_EFI_PARTITION
|
|
efi_partition, /* this must come before msdos */
|
|
#endif
|
|
+#ifdef CONFIG_FIT_PARTITION
|
|
+ fit_partition,
|
|
+#endif
|
|
#ifdef CONFIG_SGI_PARTITION
|
|
sgi_partition,
|
|
#endif
|
|
@@ -408,6 +415,11 @@ static struct block_device *add_partitio
|
|
goto out_del;
|
|
}
|
|
|
|
+#ifdef CONFIG_FIT_PARTITION
|
|
+ if (flags & ADDPART_FLAG_READONLY)
|
|
+ bdev->bd_read_only = true;
|
|
+#endif
|
|
+
|
|
/* everything is up and running, commence */
|
|
err = xa_insert(&disk->part_tbl, partno, bdev, GFP_KERNEL);
|
|
if (err)
|
|
@@ -598,6 +610,11 @@ static bool blk_add_partition(struct gen
|
|
(state->parts[p].flags & ADDPART_FLAG_RAID))
|
|
md_autodetect_dev(part->bd_dev);
|
|
|
|
+#ifdef CONFIG_FIT_PARTITION
|
|
+ if ((state->parts[p].flags & ADDPART_FLAG_ROOTDEV) && ROOT_DEV == 0)
|
|
+ ROOT_DEV = part->bd_dev;
|
|
+#endif
|
|
+
|
|
return true;
|
|
}
|
|
|
|
--- a/block/partitions/efi.c
|
|
+++ b/block/partitions/efi.c
|
|
@@ -716,6 +716,9 @@ int efi_partition(struct parsed_partitio
|
|
gpt_entry *ptes = NULL;
|
|
u32 i;
|
|
unsigned ssz = queue_logical_block_size(state->disk->queue) / 512;
|
|
+#ifdef CONFIG_FIT_PARTITION
|
|
+ u32 extra_slot = 64;
|
|
+#endif
|
|
|
|
if (!find_valid_gpt(state, &gpt, &ptes) || !gpt || !ptes) {
|
|
kfree(gpt);
|
|
@@ -749,6 +752,11 @@ int efi_partition(struct parsed_partitio
|
|
ARRAY_SIZE(ptes[i].partition_name));
|
|
utf16_le_to_7bit(ptes[i].partition_name, label_max, info->volname);
|
|
state->parts[i + 1].has_info = true;
|
|
+#ifdef CONFIG_FIT_PARTITION
|
|
+ /* If this is a U-Boot FIT volume it may have subpartitions */
|
|
+ if (!efi_guidcmp(ptes[i].partition_type_guid, PARTITION_LINUX_FIT_GUID))
|
|
+ (void) parse_fit_partitions(state, start * ssz, size * ssz, &extra_slot, 1);
|
|
+#endif
|
|
}
|
|
kfree(ptes);
|
|
kfree(gpt);
|
|
--- a/block/partitions/efi.h
|
|
+++ b/block/partitions/efi.h
|
|
@@ -52,6 +52,9 @@
|
|
#define PARTITION_LINUX_LVM_GUID \
|
|
EFI_GUID( 0xe6d6d379, 0xf507, 0x44c2, \
|
|
0xa2, 0x3c, 0x23, 0x8f, 0x2a, 0x3d, 0xf9, 0x28)
|
|
+#define PARTITION_LINUX_FIT_GUID \
|
|
+ EFI_GUID( 0xcae9be83, 0xb15f, 0x49cc, \
|
|
+ 0x86, 0x3f, 0x08, 0x1b, 0x74, 0x4a, 0x2d, 0x93)
|
|
|
|
typedef struct _gpt_header {
|
|
__le64 signature;
|
|
--- a/block/partitions/msdos.c
|
|
+++ b/block/partitions/msdos.c
|
|
@@ -564,6 +564,15 @@ static void parse_minix(struct parsed_pa
|
|
#endif /* CONFIG_MINIX_SUBPARTITION */
|
|
}
|
|
|
|
+static void parse_fit_mbr(struct parsed_partitions *state,
|
|
+ sector_t offset, sector_t size, int origin)
|
|
+{
|
|
+#ifdef CONFIG_FIT_PARTITION
|
|
+ u32 extra_slot = 64;
|
|
+ (void) parse_fit_partitions(state, offset, size, &extra_slot, 1);
|
|
+#endif /* CONFIG_FIT_PARTITION */
|
|
+}
|
|
+
|
|
static struct {
|
|
unsigned char id;
|
|
void (*parse)(struct parsed_partitions *, sector_t, sector_t, int);
|
|
@@ -575,6 +584,7 @@ static struct {
|
|
{UNIXWARE_PARTITION, parse_unixware},
|
|
{SOLARIS_X86_PARTITION, parse_solaris_x86},
|
|
{NEW_SOLARIS_X86_PARTITION, parse_solaris_x86},
|
|
+ {FIT_PARTITION, parse_fit_mbr},
|
|
{0, NULL},
|
|
};
|
|
|
|
--- a/drivers/mtd/mtd_blkdevs.c
|
|
+++ b/drivers/mtd/mtd_blkdevs.c
|
|
@@ -345,6 +345,8 @@ int add_mtd_blktrans_dev(struct mtd_blkt
|
|
gd->first_minor = (new->devnum) << tr->part_bits;
|
|
gd->minors = 1 << tr->part_bits;
|
|
gd->fops = &mtd_block_ops;
|
|
+ if (IS_ENABLED(CONFIG_FIT_PARTITION) && !mtd_type_is_nand(new->mtd))
|
|
+ gd->flags |= GENHD_FL_EXT_DEVT;
|
|
|
|
if (tr->part_bits)
|
|
if (new->devnum < 26)
|
|
--- a/drivers/mtd/ubi/block.c
|
|
+++ b/drivers/mtd/ubi/block.c
|
|
@@ -428,6 +428,9 @@ int ubiblock_create(struct ubi_volume_in
|
|
goto out_cleanup_disk;
|
|
}
|
|
gd->private_data = dev;
|
|
+#ifdef CONFIG_FIT_PARTITION
|
|
+ gd->flags |= GENHD_FL_EXT_DEVT;
|
|
+#endif
|
|
sprintf(gd->disk_name, "ubiblock%d_%d", dev->ubi_num, dev->vol_id);
|
|
set_capacity(gd, disk_capacity);
|
|
dev->gd = gd;
|
|
--- a/include/linux/msdos_partition.h
|
|
+++ b/include/linux/msdos_partition.h
|
|
@@ -31,6 +31,7 @@ enum msdos_sys_ind {
|
|
LINUX_LVM_PARTITION = 0x8e,
|
|
LINUX_RAID_PARTITION = 0xfd, /* autodetect RAID partition */
|
|
|
|
+ FIT_PARTITION = 0x2e, /* U-Boot uImage.FIT */
|
|
SOLARIS_X86_PARTITION = 0x82, /* also Linux swap partitions */
|
|
NEW_SOLARIS_X86_PARTITION = 0xbf,
|
|
|