mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-28 09:39:00 +00:00
f2a98977c4
Release Notes:
- https://github.com/wolfSSL/wolfssl/releases/tag/v5.6.0-stable
- https://github.com/wolfSSL/wolfssl/releases/tag/v5.6.2-stable
- https://github.com/wolfSSL/wolfssl/releases/tag/v5.6.3-stable
Refresh patch:
- 100-disable-hardening-check.patch
Backport patch:
- 001-fix-detection-of-cut-tool-in-configure.ac.patch
Signed-off-by: Nick Hainke <vincent@systemli.org>
(cherry picked from commit 0e83b5e6cc
)
26 lines
855 B
Diff
26 lines
855 B
Diff
From 41d248461bd9ad44193a4806ecb5361513e8944e Mon Sep 17 00:00:00 2001
|
|
From: jordan <jordan@wolfssl.com>
|
|
Date: Tue, 27 Jun 2023 13:18:25 -0500
|
|
Subject: [PATCH] fix detection of cut tool in configure.ac
|
|
|
|
---
|
|
configure.ac | 5 +++--
|
|
1 file changed, 3 insertions(+), 2 deletions(-)
|
|
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -8723,10 +8723,11 @@ echo "extern \"C\" {" >> $OPTION_FILE
|
|
echo "#endif" >> $OPTION_FILE
|
|
echo "" >> $OPTION_FILE
|
|
|
|
-# check for supported command to trim option with
|
|
+# Check for supported command to trim option with.
|
|
+# note: cut requires an argument to exit with success.
|
|
if colrm >/dev/null 2>&1 </dev/null; then
|
|
TRIM="colrm 3"
|
|
-elif cut >/dev/null 2>&1 </dev/null; then
|
|
+elif cut --version >/dev/null 2>&1 </dev/null; then
|
|
TRIM="cut -c1-2"
|
|
else
|
|
AC_MSG_ERROR([Could not find colrm or cut to make options file])
|