mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-26 00:41:17 +00:00
83d5ca2186
- make create_pbl and byte_swap as host tools - fix a bug that maybe use the cross compiler to compile create_pbl and byte_swap: # -a option appends the image for Chassis 3 devices in case of non secure boot aarch64-openwrt-linux-musl-gcc -Wall -Werror -pedantic -std=c99 -O2 -DVERSION=v1.5(release):reboot-10604-ge9216b3336 -D_GNU_SOURCE -D_XOPEN_SOURCE=700 -c -o create_pbl.o create_pbl.c cc1: note: someone does not honour COPTS correctly, passed 0 times LD create_pbl /usr/bin/ld: create_pbl.o: Relocations in generic ELF (EM: 183) /usr/bin/ld: create_pbl.o: Relocations in generic ELF (EM: 183) /usr/bin/ld: create_pbl.o: Relocations in generic ELF (EM: 183) create_pbl.o: error adding symbols: File in wrong format collect2: error: ld returned 1 exit status Makefile:43: recipe for target create_pbl failed make[4]: *** [create_pbl] Error 1 plat/nxp/tools/pbl_ch2.mk:45: recipe for target pbl failed make[3]: *** [pbl] Error 2 - add tfa- prefix to all tools in order to avoid future clashes with other toolnames Signed-off-by: Biwen Li <biwen.li@nxp.com> [added missing HOST_CFLAGS, added tfa- prefix to the tools] Signed-off-by: Petr Štetiar <ynezz@true.cz>
31 lines
905 B
Diff
31 lines
905 B
Diff
From 65e9a722b44bf28b98fe25b3b174761b47ec7dbd Mon Sep 17 00:00:00 2001
|
|
From: Biwen Li <biwen.li@nxp.com>
|
|
Date: Mon, 1 Apr 2019 13:41:55 +0800
|
|
Subject: [PATCH 2/3] plat/nxp/tools: fix a makefile bug that will use default
|
|
implicit rules
|
|
|
|
The patch fix a makefile bug that will use default implicit rules,
|
|
because do not have explicit rules for the destination files.
|
|
|
|
Signed-off-by: Biwen Li <biwen.li@nxp.com>
|
|
---
|
|
plat/nxp/tools/Makefile | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/plat/nxp/tools/Makefile b/plat/nxp/tools/Makefile
|
|
index 2095294b..0082a0be 100644
|
|
--- a/plat/nxp/tools/Makefile
|
|
+++ b/plat/nxp/tools/Makefile
|
|
@@ -53,7 +53,7 @@ ${PROJECT_2}: ${OBJECTS_2} Makefile
|
|
@echo "Built $@ successfully"
|
|
@${ECHO_BLANK_LINE}
|
|
|
|
-%.o: %.c %.h Makefile
|
|
+%.o: %.c Makefile
|
|
@echo " CC $<"
|
|
${Q}${HOSTCC} -c ${CPPFLAGS} ${CFLAGS} ${INCLUDE_PATHS} $< -o $@
|
|
|
|
--
|
|
2.17.1
|
|
|