mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-22 06:57:57 +00:00
438e593f22
Removed because they are upstream:
generic/backport-5.15/741-v6.9-01-netfilter-flowtable-validate-pppoe-header.patch
https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=linux-5.15.y&id=d06977b9a4109f8738bb276125eb6a0b772bc433
Removed because they are upstream:
generic/backport-5.15/741-v6.9-02-netfilter-flowtable-incorrect-pppoe-tuple.patch
https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=linux-5.15.y&id=e719b52d0c56989b0f3475a03a6d64f182c85b56
Manual adapted the following patches:
generic/pending-5.15/700-netfilter-nft_flow_offload-handle-netdevice-events-f.patch
generic/pending-5.15/723-net-mt7531-ensure-all-MACs-are-powered-down-before-r.patch
generic/hack-5.15/650-netfilter-add-xt_FLOWOFFLOAD-target.patch
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
(cherry picked from commit 84d0b0b925
)
43 lines
1.5 KiB
Diff
43 lines
1.5 KiB
Diff
From d43ab14605510d9d2bd257a8cd70f24ada4621b0 Mon Sep 17 00:00:00 2001
|
|
From: David Bauer <mail@david-bauer.net>
|
|
Date: Sat, 29 Feb 2020 14:27:04 +0100
|
|
Subject: [PATCH] powerpc: bootwrapper: disable uImage generation
|
|
|
|
Due to CONFIG_KERNEL_XZ symbol, the bootwrapper code tries to
|
|
instruct the mkimage to use the xz compression, which isn't
|
|
supported. This disables the uImage generation, as OpenWrt
|
|
generates individual uImages for each board using it's own
|
|
toolchain.
|
|
|
|
Signed-off-by: David Bauer <mail@david-bauer.net>
|
|
---
|
|
arch/powerpc/boot/Makefile | 9 ---------
|
|
1 file changed, 9 deletions(-)
|
|
|
|
--- a/arch/powerpc/boot/Makefile
|
|
+++ b/arch/powerpc/boot/Makefile
|
|
@@ -274,7 +274,6 @@ image-$(CONFIG_PPC_CHRP) += zImage.chrp
|
|
image-$(CONFIG_PPC_EFIKA) += zImage.chrp
|
|
image-$(CONFIG_PPC_PMAC) += zImage.pmac
|
|
image-$(CONFIG_PPC_HOLLY) += dtbImage.holly
|
|
-image-$(CONFIG_DEFAULT_UIMAGE) += uImage
|
|
image-$(CONFIG_EPAPR_BOOT) += zImage.epapr
|
|
|
|
#
|
|
@@ -410,15 +409,6 @@ $(obj)/dtbImage.%: vmlinux $(wrapperbits
|
|
$(obj)/vmlinux.strip: vmlinux
|
|
$(STRIP) -s -R .comment $< -o $@
|
|
|
|
-$(obj)/uImage: vmlinux $(wrapperbits) FORCE
|
|
- $(call if_changed,wrap,uboot)
|
|
-
|
|
-$(obj)/uImage.initrd.%: vmlinux $(obj)/dts/%.dtb $(wrapperbits) FORCE
|
|
- $(call if_changed,wrap,uboot-$*,,$(obj)/dts/$*.dtb,$(obj)/ramdisk.image.gz)
|
|
-
|
|
-$(obj)/uImage.%: vmlinux $(obj)/dts/%.dtb $(wrapperbits) FORCE
|
|
- $(call if_changed,wrap,uboot-$*,,$(obj)/dts/$*.dtb)
|
|
-
|
|
$(obj)/cuImage.initrd.%: vmlinux $(obj)/dts/%.dtb $(wrapperbits) FORCE
|
|
$(call if_changed,wrap,cuboot-$*,,$(obj)/dts/$*.dtb,$(obj)/ramdisk.image.gz)
|
|
|