mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-20 06:08:08 +00:00
9cfa5f7417
This fixes the following compile problem:
````
CC arch/mips/kernel/vpe-mt.o
arch/mips/kernel/vpe-mt.c: In function 'vpe_run':
arch/mips/kernel/vpe-mt.c:32:23: error: unused variable 'physical_memsize' [-Werror=unused-variable]
32 | unsigned long physical_memsize = 0L;
| ^~~~~~~~~~~~~~~~
cc1: all warnings being treated as errors
make[6]: *** [scripts/Makefile.build:289: arch/mips/kernel/vpe-mt.o] Error 1
````
physical_memsize was removed from upstream kernel, see:
https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=linux-5.15.y&id=5b4f6c5ff65c8551018ccea40c569afd759734c0
Fixes: 387fde0da0
("kernel: bump 5.15 to 5.15.150")
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
25 lines
688 B
Diff
25 lines
688 B
Diff
From 07ce9e9bc4dcd5ac4728e587901112eef95bbe7b Mon Sep 17 00:00:00 2001
|
|
From: Stefan Koch <stefan.koch10@gmail.com>
|
|
Date: Mon, 13 Mar 2017 23:42:00 +0100
|
|
Subject: [PATCH] lantiq: vpe nosmp
|
|
|
|
Signed-off-by: Stefan Koch <stefan.koch10@gmail.com>
|
|
---
|
|
arch/mips/kernel/vpe-mt.c | 5 ++++-
|
|
1 file changed, 4 insertions(+), 1 deletion(-)
|
|
|
|
--- a/arch/mips/kernel/vpe-mt.c
|
|
+++ b/arch/mips/kernel/vpe-mt.c
|
|
@@ -130,7 +130,10 @@ int vpe_run(struct vpe *v)
|
|
* kernels need to turn it on, even if that wasn't the pre-dvpe() state.
|
|
*/
|
|
#ifdef CONFIG_SMP
|
|
- evpe(vpeflags);
|
|
+ if (!setup_max_cpus) /* nosmp is set */
|
|
+ evpe(EVPE_ENABLE);
|
|
+ else
|
|
+ evpe(vpeflags);
|
|
#else
|
|
evpe(EVPE_ENABLE);
|
|
#endif
|