mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-21 22:47:56 +00:00
c84a3458aa
It seems the buildbots can't handle it. Added a cmake option to find the cxxabi files as they are part of the toolchain and not in the normal path. It doesn't seem to make a difference, just gets rid of cmake warnings. Added another small GCC warning fix. It's fairly minor. This has no change in compiled size, and most likely no change in behavior. Bumped the PKG_RELEASE anyway. Signed-off-by: Rosen Penev <rosenp@gmail.com>
15 lines
812 B
Diff
15 lines
812 B
Diff
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -524,9 +524,9 @@ remove_flags(-Wno-pedantic -pedantic-err
|
|
if (LIBCXX_HAS_MUSL_LIBC OR LIBCXX_TARGETING_CLANG_CL)
|
|
# musl's pthread implementations uses volatile types in their structs which is
|
|
# not a constexpr in C++11 but is in C++14, so we use C++14 with musl.
|
|
- set(LIBCXX_STANDARD_VER c++14 CACHE STRING "internal option to change build dialect")
|
|
+ set(LIBCXX_STANDARD_VER c++2a CACHE STRING "internal option to change build dialect")
|
|
else()
|
|
- set(LIBCXX_STANDARD_VER c++11 CACHE STRING "internal option to change build dialect")
|
|
+ set(LIBCXX_STANDARD_VER c++2a CACHE STRING "internal option to change build dialect")
|
|
endif()
|
|
add_compile_flags_if_supported(-std=${LIBCXX_STANDARD_VER})
|
|
add_compile_flags_if_supported("/std:${LIBCXX_STANDARD_VER}")
|