mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-20 14:13:16 +00:00
f9f62d43e4
Refreshed all patches. Compile-tested on: imx6 Runtime-tested on: imx6 Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
32 lines
996 B
Diff
32 lines
996 B
Diff
From: Felix Fietkau <nbd@nbd.name>
|
|
Subject: Upgrade to Linux 2.6.19
|
|
|
|
- Includes large parts of the patch from #1021 by dpalffy
|
|
- Includes RB532 NAND driver changes by n0-1
|
|
|
|
[john@phrozen.org: feix will add this to his upstream queue]
|
|
|
|
lede-commit: bff468813f78f81e36ebb2a3f4354de7365e640f
|
|
Signed-off-by: Felix Fietkau <nbd@nbd.name>
|
|
---
|
|
Makefile | 6 +++---
|
|
1 file changed, 3 insertions(+), 3 deletions(-)
|
|
|
|
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -701,11 +701,11 @@ KBUILD_CFLAGS += $(call cc-disable-warni
|
|
KBUILD_CFLAGS += $(call cc-disable-warning, address-of-packed-member)
|
|
|
|
ifdef CONFIG_CC_OPTIMIZE_FOR_PERFORMANCE
|
|
-KBUILD_CFLAGS += -O2
|
|
+KBUILD_CFLAGS += -O2 $(EXTRA_OPTIMIZATION)
|
|
else ifdef CONFIG_CC_OPTIMIZE_FOR_PERFORMANCE_O3
|
|
-KBUILD_CFLAGS += -O3
|
|
+KBUILD_CFLAGS += -O3 $(EXTRA_OPTIMIZATION)
|
|
else ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
|
|
-KBUILD_CFLAGS += -Os
|
|
+KBUILD_CFLAGS += -Os -fno-reorder-blocks -fno-tree-ch $(EXTRA_OPTIMIZATION)
|
|
endif
|
|
|
|
ifdef CONFIG_CC_DISABLE_WARN_MAYBE_UNINITIALIZED
|