mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-29 01:59:02 +00:00
7d7aa2fd92
This change makes the names of Broadcom targets consistent by using the common notation based on SoC/CPU ID (which is used internally anyway), bcmXXXX instead of brcmXXXX. This is even used for target TITLE in make menuconfig already, only the short target name used brcm so far. Despite, since subtargets range from bcm2708 to bcm2711, it seems appropriate to use bcm27xx instead of bcm2708 (again, as already done for BOARDNAME). This also renames the packages brcm2708-userland and brcm2708-gpu-fw. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de> Acked-by: Álvaro Fernández Rojas <noltari@gmail.com>
172 lines
3.9 KiB
Diff
172 lines
3.9 KiB
Diff
From 75967d69ea58555d12a7d9058653a69210d2ba86 Mon Sep 17 00:00:00 2001
|
|
From: Phil Elwell <pelwell@users.noreply.github.com>
|
|
Date: Wed, 18 Sep 2019 09:02:10 +0100
|
|
Subject: [PATCH] dts: Add DTS for Pi 2B rev 1.2 with BCM2837 (#3235)
|
|
|
|
Signed-off-by: Phil Elwell <phil@raspberrypi.org>
|
|
---
|
|
arch/arm/boot/dts/Makefile | 1 +
|
|
arch/arm/boot/dts/bcm2710-rpi-2-b.dts | 125 ++++++++++++++++++
|
|
arch/arm64/boot/dts/broadcom/Makefile | 2 +
|
|
.../boot/dts/broadcom/bcm2710-rpi-2-b.dts | 3 +
|
|
4 files changed, 131 insertions(+)
|
|
create mode 100644 arch/arm/boot/dts/bcm2710-rpi-2-b.dts
|
|
create mode 100644 arch/arm64/boot/dts/broadcom/bcm2710-rpi-2-b.dts
|
|
|
|
--- a/arch/arm/boot/dts/Makefile
|
|
+++ b/arch/arm/boot/dts/Makefile
|
|
@@ -7,6 +7,7 @@ dtb-$(CONFIG_ARCH_BCM2835) += \
|
|
bcm2708-rpi-zero.dtb \
|
|
bcm2708-rpi-zero-w.dtb \
|
|
bcm2709-rpi-2-b.dtb \
|
|
+ bcm2710-rpi-2-b.dtb \
|
|
bcm2710-rpi-3-b.dtb \
|
|
bcm2711-rpi-4-b.dtb \
|
|
bcm2710-rpi-3-b-plus.dtb \
|
|
--- /dev/null
|
|
+++ b/arch/arm/boot/dts/bcm2710-rpi-2-b.dts
|
|
@@ -0,0 +1,125 @@
|
|
+/dts-v1/;
|
|
+
|
|
+#include "bcm2710.dtsi"
|
|
+#include "bcm2709-rpi.dtsi"
|
|
+#include "bcm283x-rpi-smsc9514.dtsi"
|
|
+#include "bcm283x-rpi-csi1-2lane.dtsi"
|
|
+
|
|
+/ {
|
|
+ compatible = "raspberrypi,2-model-b-rev2", "brcm,bcm2837";
|
|
+ model = "Raspberry Pi 2 Model B rev 1.2";
|
|
+};
|
|
+
|
|
+&gpio {
|
|
+ spi0_pins: spi0_pins {
|
|
+ brcm,pins = <9 10 11>;
|
|
+ brcm,function = <4>; /* alt0 */
|
|
+ };
|
|
+
|
|
+ spi0_cs_pins: spi0_cs_pins {
|
|
+ brcm,pins = <8 7>;
|
|
+ brcm,function = <1>; /* output */
|
|
+ };
|
|
+
|
|
+ i2c0_pins: i2c0 {
|
|
+ brcm,pins = <0 1>;
|
|
+ brcm,function = <4>;
|
|
+ };
|
|
+
|
|
+ i2c1_pins: i2c1 {
|
|
+ brcm,pins = <2 3>;
|
|
+ brcm,function = <4>;
|
|
+ };
|
|
+
|
|
+ i2s_pins: i2s {
|
|
+ brcm,pins = <18 19 20 21>;
|
|
+ brcm,function = <4>; /* alt0 */
|
|
+ };
|
|
+
|
|
+ audio_pins: audio_pins {
|
|
+ brcm,pins = <40 45>;
|
|
+ brcm,function = <4>;
|
|
+ };
|
|
+};
|
|
+
|
|
+&uart0 {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&spi0 {
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&spi0_pins &spi0_cs_pins>;
|
|
+ cs-gpios = <&gpio 8 1>, <&gpio 7 1>;
|
|
+
|
|
+ spidev0: spidev@0{
|
|
+ compatible = "spidev";
|
|
+ reg = <0>; /* CE0 */
|
|
+ #address-cells = <1>;
|
|
+ #size-cells = <0>;
|
|
+ spi-max-frequency = <125000000>;
|
|
+ };
|
|
+
|
|
+ spidev1: spidev@1{
|
|
+ compatible = "spidev";
|
|
+ reg = <1>; /* CE1 */
|
|
+ #address-cells = <1>;
|
|
+ #size-cells = <0>;
|
|
+ spi-max-frequency = <125000000>;
|
|
+ };
|
|
+};
|
|
+
|
|
+&i2c0 {
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&i2c0_pins>;
|
|
+ clock-frequency = <100000>;
|
|
+};
|
|
+
|
|
+&i2c1 {
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&i2c1_pins>;
|
|
+ clock-frequency = <100000>;
|
|
+};
|
|
+
|
|
+&i2c2 {
|
|
+ clock-frequency = <100000>;
|
|
+};
|
|
+
|
|
+&i2s {
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&i2s_pins>;
|
|
+};
|
|
+
|
|
+&leds {
|
|
+ act_led: act {
|
|
+ label = "led0";
|
|
+ linux,default-trigger = "mmc0";
|
|
+ gpios = <&gpio 47 0>;
|
|
+ };
|
|
+
|
|
+ pwr_led: pwr {
|
|
+ label = "led1";
|
|
+ linux,default-trigger = "input";
|
|
+ gpios = <&gpio 35 0>;
|
|
+ };
|
|
+};
|
|
+
|
|
+&hdmi {
|
|
+ hpd-gpios = <&gpio 46 GPIO_ACTIVE_LOW>;
|
|
+};
|
|
+
|
|
+&audio {
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&audio_pins>;
|
|
+};
|
|
+
|
|
+/ {
|
|
+ __overrides__ {
|
|
+ act_led_gpio = <&act_led>,"gpios:4";
|
|
+ act_led_activelow = <&act_led>,"gpios:8";
|
|
+ act_led_trigger = <&act_led>,"linux,default-trigger";
|
|
+
|
|
+ pwr_led_gpio = <&pwr_led>,"gpios:4";
|
|
+ pwr_led_activelow = <&pwr_led>,"gpios:8";
|
|
+ pwr_led_trigger = <&pwr_led>,"linux,default-trigger";
|
|
+ };
|
|
+};
|
|
--- a/arch/arm64/boot/dts/broadcom/Makefile
|
|
+++ b/arch/arm64/boot/dts/broadcom/Makefile
|
|
@@ -1,7 +1,9 @@
|
|
# SPDX-License-Identifier: GPL-2.0
|
|
dtb-$(CONFIG_ARCH_BCM2835) += bcm2837-rpi-3-b.dtb \
|
|
bcm2837-rpi-3-b-plus.dtb
|
|
+dtb-$(CONFIG_ARCH_BCM2709) += bcm2710-rpi-2-b.dtb
|
|
dtb-$(CONFIG_ARCH_BCM2709) += bcm2710-rpi-3-b.dtb
|
|
+dtb-$(CONFIG_ARCH_BCM2835) += bcm2710-rpi-2-b.dtb
|
|
dtb-$(CONFIG_ARCH_BCM2835) += bcm2710-rpi-3-b.dtb
|
|
dtb-$(CONFIG_ARCH_BCM2835) += bcm2711-rpi-4-b.dtb
|
|
dtb-$(CONFIG_ARCH_BCM2835) += bcm2710-rpi-3-b-plus.dtb
|
|
--- /dev/null
|
|
+++ b/arch/arm64/boot/dts/broadcom/bcm2710-rpi-2-b.dts
|
|
@@ -0,0 +1,3 @@
|
|
+#define RPI364
|
|
+
|
|
+#include "../../../../arm/boot/dts/bcm2710-rpi-2-b.dts"
|