mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-19 13:48:06 +00:00
83672f506d
Add testing Linux kernel 5.10 for sunxi targets. Removed patches were replaced by upstream commits: - 410-v5.6-arm64-dts-allwinner-a64-olinuxino-Add-bank-supply-re.patch f0c3b29f56f0a arm64: dts: allwinner: a64: olinuxino: Add bank supply regulators - 420-v5.7-arm64-dts-allwinner-a64-olinuxino-add-user-red-LED.patch 89866b2667e0d arm64: dts: allwinner: a64: olinuxino: add user red LED - 440-add-h6-pwm.patch a7fe985633f92 pwm: sun4i: Add an optional probe for reset line b8d74644f34a8 pwm: sun4i: Prefer "mod" clock to unnamed 5b090b430d750 pwm: sun4i: Add an optional probe for bus clock fa4d81784681a pwm: sun4i: Always calculate params when applying new parameters 9f28e95b5286f pwm: sun4i: Add support to output source clock directly fdd2c12e3761f pwm: sun4i: Add support for H6 PWM - 441-arm64-dts-add-PWM-node.patch 88432f5f8469b arm64: dts: allwinner: h6: Add PWM node - 443-board-h6-orangepioneplus-fix-missing-ethernet.patch 7ee32a17e0d65 arm64: dts: allwinner: h6: orangepi-one-plus: Enable ethernet Run tested on friendlyarm,nanopi-neo (allwinner,sun8i-h3), looks all good. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
80 lines
1.6 KiB
Diff
80 lines
1.6 KiB
Diff
--- a/arch/arm/boot/dts/Makefile
|
|
+++ b/arch/arm/boot/dts/Makefile
|
|
@@ -1202,6 +1202,7 @@ dtb-$(CONFIG_MACH_SUN8I) += \
|
|
sun8i-h3-orangepi-zero-plus2.dtb \
|
|
sun8i-h3-rervision-dvk.dtb \
|
|
sun8i-h3-emlid-neutis-n5h3-devboard.dtb \
|
|
+ sun8i-h3-zeropi.dtb \
|
|
sun8i-r16-bananapi-m2m.dtb \
|
|
sun8i-r16-nintendo-nes-classic.dtb \
|
|
sun8i-r16-nintendo-super-nes-classic.dtb \
|
|
--- /dev/null
|
|
+++ b/arch/arm/boot/dts/sun8i-h3-zeropi.dts
|
|
@@ -0,0 +1,66 @@
|
|
+// SPDX-License-Identifier: (GPL-2.0+ OR MIT)
|
|
+
|
|
+#include "sun8i-h3-nanopi.dtsi"
|
|
+
|
|
+/ {
|
|
+ model = "FriendlyElec ZeroPi";
|
|
+ compatible = "friendlyarm,zeropi", "allwinner,sun8i-h3";
|
|
+
|
|
+ aliases {
|
|
+ ethernet0 = &emac;
|
|
+ };
|
|
+
|
|
+ reg_gmac_3v3: gmac-3v3 {
|
|
+ compatible = "regulator-fixed";
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&gmac_power_pin_nanopi>;
|
|
+ regulator-name = "gmac-3v3";
|
|
+ regulator-min-microvolt = <3300000>;
|
|
+ regulator-max-microvolt = <3300000>;
|
|
+ startup-delay-us = <100000>;
|
|
+ enable-active-high;
|
|
+ gpio = <&pio 3 6 GPIO_ACTIVE_HIGH>;
|
|
+ };
|
|
+};
|
|
+
|
|
+&ehci0 {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&ohci0 {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&pio {
|
|
+ gmac_power_pin_nanopi: gmac_power_pin@0 {
|
|
+ pins = "PD6";
|
|
+ function = "gpio_out";
|
|
+ };
|
|
+};
|
|
+
|
|
+&external_mdio {
|
|
+ ext_rgmii_phy: ethernet-phy@1 {
|
|
+ compatible = "ethernet-phy-ieee802.3-c22";
|
|
+ reg = <7>;
|
|
+ };
|
|
+};
|
|
+
|
|
+&emac {
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&emac_rgmii_pins>;
|
|
+ phy-supply = <®_gmac_3v3>;
|
|
+ phy-handle = <&ext_rgmii_phy>;
|
|
+ phy-mode = "rgmii";
|
|
+
|
|
+ allwinner,leds-active-low;
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&usb_otg {
|
|
+ status = "okay";
|
|
+ dr_mode = "peripheral";
|
|
+};
|
|
+
|
|
+&usbphy {
|
|
+ usb0_id_det-gpios = <&pio 6 12 GPIO_ACTIVE_HIGH>; /* PG12 */
|
|
+};
|