mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-22 06:57:57 +00:00
738b04c881
Removed upstreamed:
pending-5.15/101-Use-stddefs.h-instead-of-compiler.h.patch[1]
ipq806x/patches-5.15/122-01-clk-qcom-clk-krait-fix-wrong-div2-functions.patch[2]
bcm27xx/patches-5.15/950-0198-drm-fourcc-Add-packed-10bit-YUV-4-2-0-format.patch[3]
Manually rebased:
ramips/patches-5.15/100-PCI-mt7621-Add-MediaTek-MT7621-PCIe-host-controller-.patch[4]
Added patch/backported:
ramips/patches-5.15/107-PCI-mt7621-Add-sentinel-to-quirks-table.patch[5]
All other patches automatically rebased.
1. https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=v5.15.86&id=c160505c9b574b346031fdf2c649d19e7939ca11
2. https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=v5.15.86&id=a051e10bfc6906d29dae7a31f0773f2702edfe1b
3. https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=v5.15.86&id=ec1727f89ecd6f2252c0c75e200058819f7ce47a
4. Quilt gave this output when I applied the patch to rebase it:
% quilt push -f
Applying patch platform/100-PCI-mt7621-Add-MediaTek-MT7621-PCIe-host-controller-.patch
patching file arch/mips/ralink/Kconfig
patching file drivers/pci/controller/Kconfig
patching file drivers/pci/controller/Makefile
patching file drivers/staging/Kconfig
patching file drivers/staging/Makefile
patching file drivers/staging/mt7621-pci/Kconfig
patching file drivers/staging/mt7621-pci/Makefile
patching file drivers/staging/mt7621-pci/TODO
patching file drivers/staging/mt7621-pci/mediatek,mt7621-pci.txt
patching file drivers/staging/mt7621-pci/pci-mt7621.c
Hunk #1 FAILED at 1.
Not deleting file drivers/staging/mt7621-pci/pci-mt7621.c as content differs from patch
1 out of 1 hunk FAILED -- saving rejects to file drivers/staging/mt7621-pci/pci-mt7621.c.rej
patching file drivers/pci/controller/pcie-mt7621.c
Applied patch platform/100-PCI-mt7621-Add-MediaTek-MT7621-PCIe-host-controller-.patch (forced; needs refresh)
Upon inspecting drivers/staging/mt7621-pci/pci-mt7621.c.rej, it seems that
the original patch wants to delete drivers/staging/mt7621-pci/pci-mt7621.c
but upstream's version was not an exact match. I opted to delete that
file.
5. Suggestion by hauke: 19098934f9
"This patch is in upstream kernel, but it was backported to the old
staging driver in kernel 5.15."
Build system: x86_64
Build-tested: bcm2711/RPi4B, filogic/xiaomi_redmi-router-ax6000-ubootmod
Run-tested: bcm2711/RPi4B, filogic/xiaomi_redmi-router-ax6000-ubootmod
Signed-off-by: John Audia <therealgraysky@proton.me>
102 lines
3.2 KiB
Diff
102 lines
3.2 KiB
Diff
From abf72c0831a77e965e65088ebc992b6b5460bd2f Mon Sep 17 00:00:00 2001
|
|
From: Dave Stevenson <dave.stevenson@raspberrypi.org>
|
|
Date: Thu, 10 Jan 2019 17:58:06 +0000
|
|
Subject: [PATCH] firmware: raspberrypi: Report the fw variant during
|
|
probe
|
|
|
|
The driver already reported the firmware build date during probe.
|
|
The mailbox calls have been extended to also report the variant
|
|
1 = standard start.elf
|
|
2 = start_x.elf (includes camera stack)
|
|
3 = start_db.elf (includes assert logging)
|
|
4 = start_cd.elf (cutdown version for smallest memory footprint).
|
|
Log the variant during probe.
|
|
|
|
Signed-off-by: Dave Stevenson <dave.stevenson@raspberrypi.org>
|
|
|
|
firmware: raspberrypi: Report the fw git hash during probe
|
|
|
|
The firmware can now report the git hash from which it was built
|
|
via the mailbox, so report it during probe.
|
|
|
|
Signed-off-by: Dave Stevenson <dave.stevenson@raspberrypi.org>
|
|
---
|
|
drivers/firmware/raspberrypi.c | 40 +++++++++++++++++++++-
|
|
include/soc/bcm2835/raspberrypi-firmware.h | 2 ++
|
|
2 files changed, 41 insertions(+), 1 deletion(-)
|
|
|
|
--- a/drivers/firmware/raspberrypi.c
|
|
+++ b/drivers/firmware/raspberrypi.c
|
|
@@ -233,6 +233,15 @@ rpi_firmware_print_firmware_revision(str
|
|
{
|
|
time64_t date_and_time;
|
|
u32 packet;
|
|
+ static const char * const variant_strs[] = {
|
|
+ "unknown",
|
|
+ "start",
|
|
+ "start_x",
|
|
+ "start_db",
|
|
+ "start_cd",
|
|
+ };
|
|
+ const char *variant_str = "cmd unsupported";
|
|
+ u32 variant;
|
|
int ret = rpi_firmware_property(fw,
|
|
RPI_FIRMWARE_GET_FIRMWARE_REVISION,
|
|
&packet, sizeof(packet));
|
|
@@ -242,7 +251,35 @@ rpi_firmware_print_firmware_revision(str
|
|
|
|
/* This is not compatible with y2038 */
|
|
date_and_time = packet;
|
|
- dev_info(fw->cl.dev, "Attached to firmware from %ptT\n", &date_and_time);
|
|
+
|
|
+ ret = rpi_firmware_property(fw, RPI_FIRMWARE_GET_FIRMWARE_VARIANT,
|
|
+ &variant, sizeof(variant));
|
|
+
|
|
+ if (!ret) {
|
|
+ if (variant >= ARRAY_SIZE(variant_strs))
|
|
+ variant = 0;
|
|
+ variant_str = variant_strs[variant];
|
|
+ }
|
|
+
|
|
+ dev_info(fw->cl.dev,
|
|
+ "Attached to firmware from %ptT, variant %s\n",
|
|
+ &date_and_time, variant_str);
|
|
+}
|
|
+
|
|
+static void
|
|
+rpi_firmware_print_firmware_hash(struct rpi_firmware *fw)
|
|
+{
|
|
+ u32 hash[5];
|
|
+ int ret = rpi_firmware_property(fw,
|
|
+ RPI_FIRMWARE_GET_FIRMWARE_HASH,
|
|
+ hash, sizeof(hash));
|
|
+
|
|
+ if (ret)
|
|
+ return;
|
|
+
|
|
+ dev_info(fw->cl.dev,
|
|
+ "Firmware hash is %08x%08x%08x%08x%08x\n",
|
|
+ hash[0], hash[1], hash[2], hash[3], hash[4]);
|
|
}
|
|
|
|
static void
|
|
@@ -339,6 +376,7 @@ static int rpi_firmware_probe(struct pla
|
|
g_pdev = pdev;
|
|
|
|
rpi_firmware_print_firmware_revision(fw);
|
|
+ rpi_firmware_print_firmware_hash(fw);
|
|
rpi_register_hwmon_driver(dev, fw);
|
|
rpi_register_clk_driver(dev);
|
|
|
|
--- a/include/soc/bcm2835/raspberrypi-firmware.h
|
|
+++ b/include/soc/bcm2835/raspberrypi-firmware.h
|
|
@@ -36,6 +36,8 @@ struct rpi_firmware_property_tag_header
|
|
enum rpi_firmware_property_tag {
|
|
RPI_FIRMWARE_PROPERTY_END = 0,
|
|
RPI_FIRMWARE_GET_FIRMWARE_REVISION = 0x00000001,
|
|
+ RPI_FIRMWARE_GET_FIRMWARE_VARIANT = 0x00000002,
|
|
+ RPI_FIRMWARE_GET_FIRMWARE_HASH = 0x00000003,
|
|
|
|
RPI_FIRMWARE_SET_CURSOR_INFO = 0x00008010,
|
|
RPI_FIRMWARE_SET_CURSOR_STATE = 0x00008011,
|