mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-26 00:41:17 +00:00
55be1c3734
All modifications made by by update_kernel.sh. Build system: x86_64 Build-tested: ipq806x/R7800 Run-tested: ipq806x/R7800 [only 5.4.107] No dmesg regressions, everything functional Run-tested by @timocapa: - ramips/mt7621/{Xiaomi R3G, Redmi 2100} - Lantiq/XWAY/Fritz!Box 7320/7330 Signed-off-by: John Audia <graysky@archlinux.us> [squash, edit commit message] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
37 lines
1.2 KiB
Diff
37 lines
1.2 KiB
Diff
From 7542fb08d2726606057c4283b3a454abb195a0f5 Mon Sep 17 00:00:00 2001
|
|
From: Phil Elwell <phil@raspberrypi.org>
|
|
Date: Mon, 23 Sep 2019 09:26:41 +0100
|
|
Subject: [PATCH] kbuild: Allow .dtbo overlays to be built piecemeal
|
|
|
|
Before 4.20, it was possible to build an arbitrary overlay by copying
|
|
it to arm/boot/dts/overlays/mytest-overlay.dts and running:
|
|
|
|
make ARCH=arm overlays/mytest.dtbo
|
|
|
|
In 4.20 the .dtb build rules were centralised, requiring the dowstream
|
|
.dtbo build rules to be changed. They were, enough to support "make ...
|
|
dtbs", but not sufficiently to allow this ad-hoc, one-off building of
|
|
individual files.
|
|
|
|
Add the missing makefile rule to support this way of building.
|
|
|
|
See: https://github.com/raspberrypi/linux/issues/3250
|
|
|
|
Signed-off-by: Phil Elwell <phil@raspberrypi.org>
|
|
---
|
|
Makefile | 3 +++
|
|
1 file changed, 3 insertions(+)
|
|
|
|
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -1269,6 +1269,9 @@ ifneq ($(dtstree),)
|
|
%.dtb: include/config/kernel.release scripts_dtc
|
|
$(Q)$(MAKE) $(build)=$(dtstree) $(dtstree)/$@
|
|
|
|
+%.dtbo: prepare3 scripts_dtc
|
|
+ $(Q)$(MAKE) $(build)=$(dtstree) $(dtstree)/$@
|
|
+
|
|
PHONY += dtbs dtbs_install dtbs_check
|
|
dtbs: include/config/kernel.release scripts_dtc
|
|
$(Q)$(MAKE) $(build)=$(dtstree)
|