mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-20 06:08:08 +00:00
1f5fce27c1
All patches automatically rebased. Build system: x86_64 Build-tested: ramips/tplink_archer-a6-v3, filogic/xiaomi_redmi-router-ax6000-ubootmod Run-tested: ramips/tplink_archer-a6-v3, filogic/xiaomi_redmi-router-ax6000-ubootmod Signed-off-by: John Audia <therealgraysky@proton.me>
35 lines
1.2 KiB
Diff
35 lines
1.2 KiB
Diff
From 7742c1ba191a005a1356ff89b5fe2279d6f0ec4d Mon Sep 17 00:00:00 2001
|
|
From: =?UTF-8?q?=C3=81lvaro=20Fern=C3=A1ndez=20Rojas?= <noltari@gmail.com>
|
|
Date: Wed, 17 May 2023 18:18:43 +0200
|
|
Subject: [PATCH] mips: bmips: add PCI support
|
|
MIME-Version: 1.0
|
|
Content-Type: text/plain; charset=UTF-8
|
|
Content-Transfer-Encoding: 8bit
|
|
|
|
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
|
|
---
|
|
arch/mips/Kconfig | 1 +
|
|
arch/mips/pci/Makefile | 1 +
|
|
2 files changed, 2 insertions(+)
|
|
|
|
--- a/arch/mips/Kconfig
|
|
+++ b/arch/mips/Kconfig
|
|
@@ -275,6 +275,7 @@ config BMIPS_GENERIC
|
|
select SYNC_R4K
|
|
select COMMON_CLK
|
|
select BCM6345_L1_IRQ
|
|
+ select HAVE_PCI
|
|
select IRQ_MIPS_CPU
|
|
select DMA_NONCOHERENT
|
|
select SYS_SUPPORTS_32BIT_KERNEL
|
|
--- a/arch/mips/pci/Makefile
|
|
+++ b/arch/mips/pci/Makefile
|
|
@@ -28,6 +28,7 @@ obj-$(CONFIG_PCI_XTALK_BRIDGE) += pci-xt
|
|
# These are still pretty much in the old state, watch, go blind.
|
|
#
|
|
obj-$(CONFIG_ATH79) += fixup-ath79.o
|
|
+obj-$(CONFIG_BMIPS_GENERIC) += fixup-bmips.o
|
|
obj-$(CONFIG_MIPS_COBALT) += fixup-cobalt.o
|
|
obj-$(CONFIG_LEMOTE_FULOONG2E) += fixup-fuloong2e.o ops-loongson2.o
|
|
obj-$(CONFIG_LEMOTE_MACH2F) += fixup-lemote2f.o ops-loongson2.o
|