mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-20 14:13:16 +00:00
a34255b795
Removed upstreamed: bcm27xx/patches-5.15/950-0446-drm-vc4-Fix-timings-for-VEC-modes.patch[1] Manually rebased: patches-5.15/950-0600-xhci-quirks-add-link-TRB-quirk-for-VL805.patch bcm27xx/patches-5.15/950-0606-usb-xhci-add-VLI_TRB_CACHE_BUG-quirk.patch bcm27xx/patches-5.15/950-0717-usb-xhci-add-a-quirk-for-Superspeed-bulk-OUT-transfe.patch bcm53xx/patches-5.15/180-usb-xhci-add-support-for-performing-fake-doorbell.patch All other patches automatically rebased 1. https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=v5.15.75&id=2810061452f9b748b096ad023d318690ca519aa3 Build system: x86_64 Build-tested: bcm2711/RPi4B, mt7622/RT3200 Run-tested: bcm2711/RPi4B, mt7622/RT3200 Signed-off-by: John Audia <therealgraysky@proton.me>
43 lines
1.5 KiB
Diff
43 lines
1.5 KiB
Diff
From d43ab14605510d9d2bd257a8cd70f24ada4621b0 Mon Sep 17 00:00:00 2001
|
|
From: David Bauer <mail@david-bauer.net>
|
|
Date: Sat, 29 Feb 2020 14:27:04 +0100
|
|
Subject: [PATCH] powerpc: bootwrapper: disable uImage generation
|
|
|
|
Due to CONFIG_KERNEL_XZ symbol, the bootwrapper code tries to
|
|
instruct the mkimage to use the xz compression, which isn't
|
|
supported. This disables the uImage generation, as OpenWrt
|
|
generates individual uImages for each board using it's own
|
|
toolchain.
|
|
|
|
Signed-off-by: David Bauer <mail@david-bauer.net>
|
|
---
|
|
arch/powerpc/boot/Makefile | 9 ---------
|
|
1 file changed, 9 deletions(-)
|
|
|
|
--- a/arch/powerpc/boot/Makefile
|
|
+++ b/arch/powerpc/boot/Makefile
|
|
@@ -272,7 +272,6 @@ image-$(CONFIG_PPC_CHRP) += zImage.chrp
|
|
image-$(CONFIG_PPC_EFIKA) += zImage.chrp
|
|
image-$(CONFIG_PPC_PMAC) += zImage.pmac
|
|
image-$(CONFIG_PPC_HOLLY) += dtbImage.holly
|
|
-image-$(CONFIG_DEFAULT_UIMAGE) += uImage
|
|
image-$(CONFIG_EPAPR_BOOT) += zImage.epapr
|
|
|
|
#
|
|
@@ -404,15 +403,6 @@ $(obj)/dtbImage.%: vmlinux $(wrapperbits
|
|
$(obj)/vmlinux.strip: vmlinux
|
|
$(STRIP) -s -R .comment $< -o $@
|
|
|
|
-$(obj)/uImage: vmlinux $(wrapperbits) FORCE
|
|
- $(call if_changed,wrap,uboot)
|
|
-
|
|
-$(obj)/uImage.initrd.%: vmlinux $(obj)/dts/%.dtb $(wrapperbits) FORCE
|
|
- $(call if_changed,wrap,uboot-$*,,$(obj)/dts/$*.dtb,$(obj)/ramdisk.image.gz)
|
|
-
|
|
-$(obj)/uImage.%: vmlinux $(obj)/dts/%.dtb $(wrapperbits) FORCE
|
|
- $(call if_changed,wrap,uboot-$*,,$(obj)/dts/$*.dtb)
|
|
-
|
|
$(obj)/cuImage.initrd.%: vmlinux $(obj)/dts/%.dtb $(wrapperbits) FORCE
|
|
$(call if_changed,wrap,cuboot-$*,,$(obj)/dts/$*.dtb,$(obj)/ramdisk.image.gz)
|
|
|