mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-27 09:12:39 +00:00
db18cee2d7
Signed-off-by: Hans Dedecker <dedeckeh@gmail.com>
12 lines
379 B
Diff
12 lines
379 B
Diff
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -42,7 +42,7 @@ HOSTCC ?= $(CC)
|
|
DEFINES += -D_GNU_SOURCE
|
|
# Turn on transparent support for LFS
|
|
DEFINES += -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE
|
|
-CCOPTS = -O2
|
|
+CCOPTS = -O2 $(EXTRA_CCOPTS)
|
|
WFLAGS := -Wall -Wstrict-prototypes -Wmissing-prototypes
|
|
WFLAGS += -Wmissing-declarations -Wold-style-definition -Wformat=2
|
|
|