openwrt/package/devel/strace/patches/010-m4.patch
Rosen Penev 9a329c4d87 strace: remove code coverage makefile var
It relies on a custom ax_code_coverage.m4 file included with strace.
Unfortunately, this conflicts with the one included with
autoconf-macros. Instead of creating a huge patch to fix it, just remove
the variable as code coverage is not used here.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
2021-11-02 23:37:19 +01:00

11 lines
301 B
Diff

--- a/Makefile.am
+++ b/Makefile.am
@@ -408,7 +408,6 @@ strace_LDADD += $(libiberty_LIBS)
endif
endif
-@CODE_COVERAGE_RULES@
CODE_COVERAGE_BRANCH_COVERAGE = 1
CODE_COVERAGE_GENHTML_OPTIONS = $(CODE_COVERAGE_GENHTML_OPTIONS_DEFAULT) \
--prefix $(shell cd $(abs_top_srcdir)/.. && pwd || echo .)