mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-22 06:57:57 +00:00
cae1b504e9
Qualcomm recently committed a new branch (12.5.r2) targeting kernel 6.6. This lets us clean up a few patches particularly the one for "C22/C45" mdio. A quick way to see what changed for IPQ807x/6018 was to list the files produced during build (**/*.o), replace the extension with ".c", and doing a `git log`. Filtering from those commits, ones of particular interest are listed below: ``` 2024-04-16 - 0d8f30aa - fix compile issue on hk with linux style build 2024-01-29 - 636464f7 - update the check for port link notify 2024-01-24 - 30c10e7f - enable and disable loopback for xgmac to fix qm stuck issue 2024-01-15 - b6ea10aa - update the the APIs to access switch 2024-01-08 - a1687502 - Disable Tx bridge mac before power off the PHY 2024-01-07 - 3eafb613 - support led configure for malibu phy 2024-01-07 - 5c1af60d - remove phy type check from mac reset when mode switch 2023-12-17 - 79d0b1e8 - remove the PHY access APIs in ssdk_plat.c 2023-12-16 - b2953740 - Update mii read/write functions 2023-12-11 - 37f2eac3 - add port id check for fdb entry 2023-12-11 - d040ca4d - support mdio clause45 on kernel6.6 2023-12-07 - 11494fbc - use barrier mw() during access fdb entry table 2023-12-03 - 8e40a284 - fix build warnings on kernel6.6 2023-11-10 - 10aa0a02 - change speed value when call ssdk_port_link_notify 2023-11-06 - ee4c4a60 - Update mac bitmap value of L3 table on MAC delete 2023-11-03 - 7cd27d39 - support 10G phy common feature 2023-10-30 - 383cc0d2 - fix mactype and mux select issue 2023-10-24 - decf534a - support autoneg status query on force port 2023-10-11 - 111d574e - move ssdk_led_init to regi_init 2023-10-08 - 6b14c142 - the combo port also need to parse SFP pins 2023-10-03 - fb2e0401 - fix port5 interface mode switch issue in erp case ``` Verified with users on QNAP 301W, NBG7815, and myself on Dynalink DL-WRX36 that everything is functional, including LEDS. Signed-off-by: Sean Khan <datapronix@protonmail.com> Link: https://github.com/openwrt/openwrt/pull/15379 Signed-off-by: Robert Marko <robimarko@gmail.com>
51 lines
1.7 KiB
Diff
51 lines
1.7 KiB
Diff
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -1,17 +1,19 @@
|
|
-include ./config
|
|
-
|
|
ifndef PRJ_PATH
|
|
PRJ_PATH=$(shell pwd)
|
|
endif
|
|
export PRJ_PATH
|
|
|
|
-include ./make/config.mk
|
|
-include ./make/tools.mk
|
|
-include ./make/$(OS)_opt.mk
|
|
+include $(PRJ_PATH)/config
|
|
+
|
|
+include $(PRJ_PATH)/make/config.mk
|
|
+include $(PRJ_PATH)/make/tools.mk
|
|
+include $(PRJ_PATH)/make/$(OS)_opt.mk
|
|
|
|
SUB_DIR=$(patsubst %/, %, $(dir $(wildcard src/*/Makefile)))
|
|
SUB_LIB=$(subst src/, , $(SUB_DIR))
|
|
|
|
+include $(PRJ_PATH)/Makefile.modules
|
|
+
|
|
####################################################################
|
|
# SSDK-Style Makefile
|
|
####################################################################
|
|
@@ -27,11 +29,7 @@ all: $(BIN_DIR) kslib
|
|
# LNX Modules-Style Makefile
|
|
####################################################################
|
|
modules: $(BIN_DIR) kslib_c
|
|
- mkdir -p ./temp/;cp * ./temp -a;cd ./temp;cp ../Makefile.modules ./Makefile;
|
|
- make -C $(SYS_PATH) M=$(PRJ_PATH)/temp $(LNX_MAKEOPTS) modules
|
|
- cp $(PRJ_PATH)/temp/Module.symvers $(PRJ_PATH)/Module.symvers;
|
|
- cp temp/*.ko build/bin;
|
|
- rm -Rf ./temp/*.o ./temp/*.ko ./temp/*.a
|
|
+ @$(MAKE) -C $(SYS_PATH) M=$(PRJ_PATH) $(LNX_MAKEOPTS) modules
|
|
@echo "---Build [SSDK-$(VERSION)] at $(BUILD_DATE) finished."
|
|
|
|
kslib_c:
|
|
--- a/make/linux_opt.mk
|
|
+++ b/make/linux_opt.mk
|
|
@@ -778,6 +778,6 @@ LOCAL_CFLAGS += $(CPU_CFLAG) -D"KBUILD_M
|
|
####################################################################
|
|
# cflags for LNX Modules-Style Makefile
|
|
####################################################################
|
|
-LNX_LOCAL_CFLAGS += $(MODULE_INC) $(MODULE_CFLAG) ${EXTRA_INC} -DFALLTHROUGH
|
|
+LNX_LOCAL_CFLAGS = $(MODULE_INC) $(MODULE_CFLAG) ${EXTRA_INC} -DFALLTHROUGH
|
|
export LNX_LOCAL_CFLAGS
|
|
|