mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-22 06:57:57 +00:00
cf08db988b
Backport initial LEDs hw control support. Currently this is limited to
only rx/tx and link events for the netdev trigger but the API got
accepted and the additional modes are working on and will be backported
later.
Refresh every patch and add the additional config flag for QCA8K new
LEDs support.
Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
(cherry picked from commit 0a4b309f41
)
40 lines
1.4 KiB
Diff
40 lines
1.4 KiB
Diff
From 128dc09b0af36772062142ce9e85b19c84ac789a Mon Sep 17 00:00:00 2001
|
|
From: Daniel Golle <daniel@makrotopia.org>
|
|
Date: Tue, 28 Feb 2023 17:53:37 +0000
|
|
Subject: [PATCH] net: phy: add driver for MediaTek 2.5G PHY
|
|
|
|
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
|
|
---
|
|
drivers/net/phy/Kconfig | 7 ++
|
|
drivers/net/phy/Makefile | 1 +
|
|
drivers/net/phy/mediatek-2p5ge.c | 220 +++++++++++++++++++++++++++++++
|
|
3 files changed, 226 insertions(+)
|
|
create mode 100644 drivers/net/phy/mediatek-2p5ge.c
|
|
|
|
--- a/drivers/net/phy/Kconfig
|
|
+++ b/drivers/net/phy/Kconfig
|
|
@@ -305,6 +305,13 @@ config MEDIATEK_GE_SOC_PHY
|
|
present in the SoCs efuse and will dynamically calibrate VCM
|
|
(common-mode voltage) during startup.
|
|
|
|
+config MEDIATEK_2P5G_PHY
|
|
+ tristate "MediaTek 2.5G Ethernet PHY"
|
|
+ depends on (ARCH_MEDIATEK && ARM64) || COMPILE_TEST
|
|
+ default NET_MEDIATEK_SOC
|
|
+ help
|
|
+ Supports the MediaTek 2.5G Ethernet PHY.
|
|
+
|
|
config MICREL_PHY
|
|
tristate "Micrel PHYs"
|
|
help
|
|
--- a/drivers/net/phy/Makefile
|
|
+++ b/drivers/net/phy/Makefile
|
|
@@ -80,6 +80,7 @@ obj-$(CONFIG_MARVELL_10G_PHY) += marvell
|
|
obj-$(CONFIG_MARVELL_PHY) += marvell.o
|
|
obj-$(CONFIG_MARVELL_88X2222_PHY) += marvell-88x2222.o
|
|
obj-$(CONFIG_MAXLINEAR_GPHY) += mxl-gpy.o
|
|
+obj-$(CONFIG_MEDIATEK_2P5G_PHY) += mediatek-2p5ge.o
|
|
obj-$(CONFIG_MEDIATEK_GE_PHY) += mediatek-ge.o
|
|
obj-$(CONFIG_MEDIATEK_GE_SOC_PHY) += mediatek-ge-soc.o
|
|
obj-$(CONFIG_MESON_GXL_PHY) += meson-gxl.o
|