mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-20 22:23:27 +00:00
738b04c881
Removed upstreamed:
pending-5.15/101-Use-stddefs.h-instead-of-compiler.h.patch[1]
ipq806x/patches-5.15/122-01-clk-qcom-clk-krait-fix-wrong-div2-functions.patch[2]
bcm27xx/patches-5.15/950-0198-drm-fourcc-Add-packed-10bit-YUV-4-2-0-format.patch[3]
Manually rebased:
ramips/patches-5.15/100-PCI-mt7621-Add-MediaTek-MT7621-PCIe-host-controller-.patch[4]
Added patch/backported:
ramips/patches-5.15/107-PCI-mt7621-Add-sentinel-to-quirks-table.patch[5]
All other patches automatically rebased.
1. https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=v5.15.86&id=c160505c9b574b346031fdf2c649d19e7939ca11
2. https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=v5.15.86&id=a051e10bfc6906d29dae7a31f0773f2702edfe1b
3. https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=v5.15.86&id=ec1727f89ecd6f2252c0c75e200058819f7ce47a
4. Quilt gave this output when I applied the patch to rebase it:
% quilt push -f
Applying patch platform/100-PCI-mt7621-Add-MediaTek-MT7621-PCIe-host-controller-.patch
patching file arch/mips/ralink/Kconfig
patching file drivers/pci/controller/Kconfig
patching file drivers/pci/controller/Makefile
patching file drivers/staging/Kconfig
patching file drivers/staging/Makefile
patching file drivers/staging/mt7621-pci/Kconfig
patching file drivers/staging/mt7621-pci/Makefile
patching file drivers/staging/mt7621-pci/TODO
patching file drivers/staging/mt7621-pci/mediatek,mt7621-pci.txt
patching file drivers/staging/mt7621-pci/pci-mt7621.c
Hunk #1 FAILED at 1.
Not deleting file drivers/staging/mt7621-pci/pci-mt7621.c as content differs from patch
1 out of 1 hunk FAILED -- saving rejects to file drivers/staging/mt7621-pci/pci-mt7621.c.rej
patching file drivers/pci/controller/pcie-mt7621.c
Applied patch platform/100-PCI-mt7621-Add-MediaTek-MT7621-PCIe-host-controller-.patch (forced; needs refresh)
Upon inspecting drivers/staging/mt7621-pci/pci-mt7621.c.rej, it seems that
the original patch wants to delete drivers/staging/mt7621-pci/pci-mt7621.c
but upstream's version was not an exact match. I opted to delete that
file.
5. Suggestion by hauke: 19098934f9
"This patch is in upstream kernel, but it was backported to the old
staging driver in kernel 5.15."
Build system: x86_64
Build-tested: bcm2711/RPi4B, filogic/xiaomi_redmi-router-ax6000-ubootmod
Run-tested: bcm2711/RPi4B, filogic/xiaomi_redmi-router-ax6000-ubootmod
Signed-off-by: John Audia <therealgraysky@proton.me>
120 lines
3.6 KiB
Diff
120 lines
3.6 KiB
Diff
From: Sergio Paracuellos <sergio.paracuellos@gmail.com>
|
|
Date: Tue, 7 Dec 2021 11:49:21 +0100
|
|
Subject: [PATCH] PCI: mt7621: Move MIPS setup to pcibios_root_bridge_prepare()
|
|
|
|
On the MIPS ralink mt7621 platform, we need to set up I/O coherency units
|
|
based on the host bridge apertures.
|
|
|
|
To remove this arch dependency from the driver itself, move the coherency
|
|
setup from the driver to pcibios_root_bridge_prepare().
|
|
|
|
[bhelgaas: squash add/remove into one patch, commit log]
|
|
Link: https://lore.kernel.org/r/20211207104924.21327-3-sergio.paracuellos@gmail.com
|
|
Link: https://lore.kernel.org/r/20211207104924.21327-4-sergio.paracuellos@gmail.com
|
|
Signed-off-by: Sergio Paracuellos <sergio.paracuellos@gmail.com>
|
|
Signed-off-by: Bjorn Helgaas <bhelgaas@google.com>
|
|
Reviewed-by: Guenter Roeck <linux@roeck-us.net> # arch/mips
|
|
Acked-by: Thomas Bogendoerfer <tsbogend@alpha.franken.de> # arch/mips
|
|
---
|
|
|
|
--- a/arch/mips/ralink/mt7621.c
|
|
+++ b/arch/mips/ralink/mt7621.c
|
|
@@ -10,6 +10,8 @@
|
|
#include <linux/slab.h>
|
|
#include <linux/sys_soc.h>
|
|
#include <linux/memblock.h>
|
|
+#include <linux/pci.h>
|
|
+#include <linux/bug.h>
|
|
|
|
#include <asm/bootinfo.h>
|
|
#include <asm/mipsregs.h>
|
|
@@ -25,6 +27,35 @@
|
|
static u32 detect_magic __initdata;
|
|
static struct ralink_soc_info *soc_info_ptr;
|
|
|
|
+int pcibios_root_bridge_prepare(struct pci_host_bridge *bridge)
|
|
+{
|
|
+ struct resource_entry *entry;
|
|
+ resource_size_t mask;
|
|
+
|
|
+ entry = resource_list_first_type(&bridge->windows, IORESOURCE_MEM);
|
|
+ if (!entry) {
|
|
+ pr_err("Cannot get memory resource\n");
|
|
+ return -EINVAL;
|
|
+ }
|
|
+
|
|
+ if (mips_cps_numiocu(0)) {
|
|
+ /*
|
|
+ * Hardware doesn't accept mask values with 1s after
|
|
+ * 0s (e.g. 0xffef), so warn if that's happen
|
|
+ */
|
|
+ mask = ~(entry->res->end - entry->res->start) & CM_GCR_REGn_MASK_ADDRMASK;
|
|
+ WARN_ON(mask && BIT(ffz(~mask)) - 1 != ~mask);
|
|
+
|
|
+ write_gcr_reg1_base(entry->res->start);
|
|
+ write_gcr_reg1_mask(mask | CM_GCR_REGn_MASK_CMTGT_IOCU0);
|
|
+ pr_info("PCI coherence region base: 0x%08llx, mask/settings: 0x%08llx\n",
|
|
+ (unsigned long long)read_gcr_reg1_base(),
|
|
+ (unsigned long long)read_gcr_reg1_mask());
|
|
+ }
|
|
+
|
|
+ return 0;
|
|
+}
|
|
+
|
|
phys_addr_t mips_cpc_default_phys_base(void)
|
|
{
|
|
panic("Cannot detect cpc address");
|
|
--- a/drivers/pci/controller/pcie-mt7621.c
|
|
+++ b/drivers/pci/controller/pcie-mt7621.c
|
|
@@ -208,37 +208,6 @@ static inline void mt7621_control_deasse
|
|
reset_control_assert(port->pcie_rst);
|
|
}
|
|
|
|
-static int setup_cm_memory_region(struct pci_host_bridge *host)
|
|
-{
|
|
- struct mt7621_pcie *pcie = pci_host_bridge_priv(host);
|
|
- struct device *dev = pcie->dev;
|
|
- struct resource_entry *entry;
|
|
- resource_size_t mask;
|
|
-
|
|
- entry = resource_list_first_type(&host->windows, IORESOURCE_MEM);
|
|
- if (!entry) {
|
|
- dev_err(dev, "cannot get memory resource\n");
|
|
- return -EINVAL;
|
|
- }
|
|
-
|
|
- if (mips_cps_numiocu(0)) {
|
|
- /*
|
|
- * FIXME: hardware doesn't accept mask values with 1s after
|
|
- * 0s (e.g. 0xffef), so it would be great to warn if that's
|
|
- * about to happen
|
|
- */
|
|
- mask = ~(entry->res->end - entry->res->start);
|
|
-
|
|
- write_gcr_reg1_base(entry->res->start);
|
|
- write_gcr_reg1_mask(mask | CM_GCR_REGn_MASK_CMTGT_IOCU0);
|
|
- dev_info(dev, "PCI coherence region base: 0x%08llx, mask/settings: 0x%08llx\n",
|
|
- (unsigned long long)read_gcr_reg1_base(),
|
|
- (unsigned long long)read_gcr_reg1_mask());
|
|
- }
|
|
-
|
|
- return 0;
|
|
-}
|
|
-
|
|
static int mt7621_pcie_parse_port(struct mt7621_pcie *pcie,
|
|
struct device_node *node,
|
|
int slot)
|
|
@@ -557,12 +526,6 @@ static int mt7621_pcie_probe(struct plat
|
|
goto remove_resets;
|
|
}
|
|
|
|
- err = setup_cm_memory_region(bridge);
|
|
- if (err) {
|
|
- dev_err(dev, "error setting up iocu mem regions\n");
|
|
- goto remove_resets;
|
|
- }
|
|
-
|
|
return mt7621_pcie_register_host(bridge);
|
|
|
|
remove_resets:
|