mirror of
https://github.com/openwrt/openwrt.git
synced 2025-01-01 11:36:49 +00:00
f4fb63d2ab
MDIO drivers were moved into their own sub directory of networking drivers. This has caused the AR40xx driver to probe before MDIO drivers and that wont work as it depends on the MDIO bus to be up so it can be fetched. Lets solve it by moving the AR40xx into MDIO folder so they get probed like before. Signed-off-by: Robert Marko <robert.marko@sartura.hr>
51 lines
1.8 KiB
Diff
51 lines
1.8 KiB
Diff
From f825cdc8bfde7616a14e2163f16303a8973031d2 Mon Sep 17 00:00:00 2001
|
|
From: Robert Marko <robert.marko@sartura.hr>
|
|
Date: Wed, 7 Oct 2020 17:38:48 +0200
|
|
Subject: [PATCH] net: phy: Add Qualcom QCA807x driver
|
|
|
|
This adds driver for the Qualcomm QCA8072 and QCA8075 PHY-s.
|
|
|
|
They are 2 or 5 port IEEE 802.3 clause 22 compliant 10BASE-Te, 100BASE-TX and 1000BASE-T PHY-s.
|
|
|
|
They feature 2 SerDes, one for PSGMII or QSGMII connection with MAC, while second one is SGMII for connection to MAC or fiber.
|
|
|
|
Both models have a combo port that supports 1000BASE-X and 100BASE-FX fiber.
|
|
|
|
Each PHY inside of QCA807x series has 4 digitally controlled output only pins that natively drive LED-s.
|
|
But some vendors used these to driver generic LED-s controlled by userspace,
|
|
so lets enable registering each PHY as GPIO controller and add driver for it.
|
|
|
|
These are commonly used in Qualcomm IPQ40xx, IPQ60xx and IPQ807x boards.
|
|
|
|
Signed-off-by: Robert Marko <robert.marko@sartura.hr>
|
|
---
|
|
drivers/net/phy/Kconfig | 6 ++++++
|
|
drivers/net/phy/Makefile | 1 +
|
|
2 files changed, 7 insertions(+)
|
|
|
|
--- a/drivers/net/phy/Kconfig
|
|
+++ b/drivers/net/phy/Kconfig
|
|
@@ -314,6 +314,12 @@ config AT803X_PHY
|
|
help
|
|
Currently supports the AR8030, AR8031, AR8033 and AR8035 model
|
|
|
|
+config QCA807X_PHY
|
|
+ tristate "Qualcomm QCA807X PHYs"
|
|
+ depends on OF_MDIO
|
|
+ help
|
|
+ Currently supports the QCA8072 and QCA8075 models.
|
|
+
|
|
config QSEMI_PHY
|
|
tristate "Quality Semiconductor PHYs"
|
|
help
|
|
--- a/drivers/net/phy/Makefile
|
|
+++ b/drivers/net/phy/Makefile
|
|
@@ -85,6 +85,7 @@ obj-$(CONFIG_MICROSEMI_PHY) += mscc/
|
|
obj-$(CONFIG_NATIONAL_PHY) += national.o
|
|
obj-$(CONFIG_NXP_TJA11XX_PHY) += nxp-tja11xx.o
|
|
obj-$(CONFIG_QSEMI_PHY) += qsemi.o
|
|
+obj-$(CONFIG_QCA807X_PHY) += qca807x.o
|
|
obj-$(CONFIG_REALTEK_PHY) += realtek.o
|
|
obj-$(CONFIG_RENESAS_PHY) += uPD60620.o
|
|
obj-$(CONFIG_ROCKCHIP_PHY) += rockchip.o
|