mirror of
https://github.com/openwrt/openwrt.git
synced 2025-01-09 22:42:57 +00:00
72878e3244
This fixes the following compile error seen on the mpc85xx target: CC [M] /linux-mpc85xx_p2020/backports-5.7-rc3-1/drivers/net/wireless/intersil/orinoco/main.o In file included from /builder/shared-workdir/build/staging_dir/toolchain-powerpc_8540_gcc-8.4.0_musl/include/stddef.h:17, from /linux-mpc85xx_p2020/backports-5.7-rc3-1/include/uapi/linux/wireless.h:77, from /linux-mpc85xx_p2020/backports-5.7-rc3-1/include/linux/wireless.h:13, from /linux-mpc85xx_p2020/backports-5.7-rc3-1/drivers/net/wireless/intersil/orinoco/main.c:89: /builder/shared-workdir/build/staging_dir/toolchain-powerpc_8540_gcc-8.4.0_musl/include/bits/alltypes.h:106:15: error: conflicting types for 'ptrdiff_t' typedef _Addr ptrdiff_t; ^~~~~~~~~ In file included from /linux-mpc85xx_p2020/backports-5.7-rc3-1/backport-include/linux/types.h:4, from ./include/linux/list.h:5, from /linux-mpc85xx_p2020/backports-5.7-rc3-1/backport-include/linux/list.h:3, from ./include/linux/module.h:9, from /linux-mpc85xx_p2020/backports-5.7-rc3-1/backport-include/linux/module.h:3, from /linux-mpc85xx_p2020/backports-5.7-rc3-1/drivers/net/wireless/intersil/orinoco/main.c:79: ./include/linux/types.h:65:28: note: previous declaration of 'ptrdiff_t' was here typedef __kernel_ptrdiff_t ptrdiff_t; ^~~~~~~~~ scripts/Makefile.build:265: recipe for target '/linux-mpc85xx_p2020/backports-5.7-rc3-1/drivers/net/wireless/intersil/orinoco/main.o' failed Fixes:d6b158b869
("mac80211: Update to 4.19.137-1") Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> (cherry picked from commit04b1a11f5c
)
34 lines
1.3 KiB
Diff
34 lines
1.3 KiB
Diff
From 1b9ae0c92925ac40489be526d67d0010d0724ce0 Mon Sep 17 00:00:00 2001
|
|
From: Hauke Mehrtens <hauke@hauke-m.de>
|
|
Date: Thu, 21 May 2020 22:14:22 +0200
|
|
Subject: [PATCH] wireless: Use linux/stddef.h instead of stddef.h
|
|
|
|
When compiling inside the kernel include linux/stddef.h instead of
|
|
stddef.h. When I compile this header file in backports for power PC I
|
|
run into a conflict with ptrdiff_t. I was unable to reproduce this in
|
|
mainline kernel. I still would like to fix this problem in the kernel.
|
|
|
|
Fixes: 6989310f5d43 ("wireless: Use offsetof instead of custom macro.")
|
|
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
|
|
Link: https://lore.kernel.org/r/20200521201422.16493-1-hauke@hauke-m.de
|
|
Signed-off-by: Johannes Berg <johannes.berg@intel.com>
|
|
---
|
|
include/uapi/linux/wireless.h | 6 +++++-
|
|
1 file changed, 5 insertions(+), 1 deletion(-)
|
|
|
|
--- a/include/uapi/linux/wireless.h
|
|
+++ b/include/uapi/linux/wireless.h
|
|
@@ -74,7 +74,11 @@
|
|
#include <linux/socket.h> /* for "struct sockaddr" et al */
|
|
#include <linux/if.h> /* for IFNAMSIZ and co... */
|
|
|
|
-#include <stddef.h> /* for offsetof */
|
|
+#ifdef __KERNEL__
|
|
+# include <linux/stddef.h> /* for offsetof */
|
|
+#else
|
|
+# include <stddef.h> /* for offsetof */
|
|
+#endif
|
|
|
|
/***************************** VERSION *****************************/
|
|
/*
|