mirror of
https://github.com/openwrt/openwrt.git
synced 2025-01-06 13:58:53 +00:00
cad32b0350
Update to the latest upstream release to include recent improvements and bugfixes. Also refresh local patches. Link: https://github.com/libbpf/libbpf/releases/tag/v1.3.0 Signed-off-by: Tony Ambardar <itugrok@yahoo.com>
11 lines
297 B
Diff
11 lines
297 B
Diff
--- a/src/Makefile
|
|
+++ b/src/Makefile
|
|
@@ -34,6 +34,7 @@ ALL_CFLAGS := $(INCLUDES)
|
|
|
|
SHARED_CFLAGS += -fPIC -fvisibility=hidden -DSHARED
|
|
|
|
+CFLAGS = $(EXTRA_CFLAGS)
|
|
CFLAGS ?= -g -O2 -Werror -Wall -std=gnu89
|
|
ALL_CFLAGS += $(CFLAGS) \
|
|
-D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 \
|