openwrt/tools/lzop/patches/001-add-cmake-ENABLE_DOCS-configurable.patch
Rosen Penev 337b0c80cb
tools: refresh all patches
Refresh all tools patches now that tools/refresh correctly works.

CI now checks for them and actively complain if tools have unrefreshed
patches.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
[ reword commit message ]
Link: https://github.com/openwrt/openwrt/pull/15524
Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
2024-05-23 11:49:03 +02:00

25 lines
790 B
Diff

--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -50,6 +50,9 @@ endif()
project(lzop VERSION 1.04 LANGUAGES C)
+# configuration options
+option(ENABLE_DOCS "Install documentation." ON)
+
# install directories
if(NOT CMAKE_INSTALL_PREFIX)
message(FATAL_ERROR "ERROR: CMAKE_INSTALL_PREFIX is not defined.")
@@ -186,9 +189,11 @@ if(DEFINED CMAKE_INSTALL_FULL_LIBDIR)
install(TARGETS lzop DESTINATION "${CMAKE_INSTALL_FULL_BINDIR}")
+if(ENABLE_DOCS)
set(f AUTHORS COPYING NEWS README THANKS doc/lzop.html doc/lzop.man doc/lzop.pod doc/lzop.ps doc/lzop.tex doc/lzop.txt)
install(FILES ${f} DESTINATION "${CMAKE_INSTALL_FULL_DOCDIR}")
install(FILES doc/lzop.1 DESTINATION "${CMAKE_INSTALL_FULL_MANDIR}/man1")
+endif() # ENABLE_DOCS
endif() # CMAKE_INSTALL_FULL_LIBDIR