openwrt/target/linux/realtek/patches-5.4/700-net-dsa-add-support-for-rtl838x-switch.patch
John Crispin 2b88563ee5 realtek: update the tree to the latest refactored version
* rename the target to realtek
* add refactored DSA driver
* add latest gpio driver
* lots of arch cleanups
* new irq driver
* additional boards

Signed-off-by: Bert Vermeulen <bert@biot.com>
Signed-off-by: Birger Koblitz <mail@birger-koblitz.de>
Signed-off-by: Sander Vanheule <sander@svanheule.net>
Signed-off-by: Bjørn Mork <bjorn@mork.no>
Signed-off-by: John Crispin <john@phrozen.org>
2020-11-26 13:29:27 +01:00

23 lines
801 B
Diff

Index: linux-5.4.77/drivers/net/dsa/Kconfig
===================================================================
--- linux-5.4.77.orig/drivers/net/dsa/Kconfig
+++ linux-5.4.77/drivers/net/dsa/Kconfig
@@ -63,6 +63,8 @@ config NET_DSA_QCA8K
This enables support for the Qualcomm Atheros QCA8K Ethernet
switch chips.
+source "drivers/net/dsa/rtl83xx/Kconfig"
+
config NET_DSA_REALTEK_SMI
tristate "Realtek SMI Ethernet switch family support"
depends on NET_DSA
Index: linux-5.4.77/drivers/net/dsa/Makefile
===================================================================
--- linux-5.4.77.orig/drivers/net/dsa/Makefile
+++ linux-5.4.77/drivers/net/dsa/Makefile
@@ -21,3 +21,4 @@ obj-y += b53/
obj-y += microchip/
obj-y += mv88e6xxx/
obj-y += sja1105/
+obj-y += rtl83xx/