mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-20 14:13:16 +00:00
2b88563ee5
* rename the target to realtek * add refactored DSA driver * add latest gpio driver * lots of arch cleanups * new irq driver * additional boards Signed-off-by: Bert Vermeulen <bert@biot.com> Signed-off-by: Birger Koblitz <mail@birger-koblitz.de> Signed-off-by: Sander Vanheule <sander@svanheule.net> Signed-off-by: Bjørn Mork <bjorn@mork.no> Signed-off-by: John Crispin <john@phrozen.org>
23 lines
801 B
Diff
23 lines
801 B
Diff
Index: linux-5.4.77/drivers/net/dsa/Kconfig
|
|
===================================================================
|
|
--- linux-5.4.77.orig/drivers/net/dsa/Kconfig
|
|
+++ linux-5.4.77/drivers/net/dsa/Kconfig
|
|
@@ -63,6 +63,8 @@ config NET_DSA_QCA8K
|
|
This enables support for the Qualcomm Atheros QCA8K Ethernet
|
|
switch chips.
|
|
|
|
+source "drivers/net/dsa/rtl83xx/Kconfig"
|
|
+
|
|
config NET_DSA_REALTEK_SMI
|
|
tristate "Realtek SMI Ethernet switch family support"
|
|
depends on NET_DSA
|
|
Index: linux-5.4.77/drivers/net/dsa/Makefile
|
|
===================================================================
|
|
--- linux-5.4.77.orig/drivers/net/dsa/Makefile
|
|
+++ linux-5.4.77/drivers/net/dsa/Makefile
|
|
@@ -21,3 +21,4 @@ obj-y += b53/
|
|
obj-y += microchip/
|
|
obj-y += mv88e6xxx/
|
|
obj-y += sja1105/
|
|
+obj-y += rtl83xx/
|