mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-19 13:48:06 +00:00
66b6414a20
Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
168 lines
4.1 KiB
Plaintext
168 lines
4.1 KiB
Plaintext
From 64eca7ad058cff861b48cdead8dee40dfc284e9e Mon Sep 17 00:00:00 2001
|
|
From: William Zhang <william.zhang@broadcom.com>
|
|
Date: Wed, 8 Jun 2022 11:04:36 -0700
|
|
Subject: [PATCH] arm64: dts: Add DTS files for bcmbca SoC BCM6856
|
|
|
|
Add DTS for ARMv8 based broadband SoC BCM6856. bcm6856.dtsi is the
|
|
SoC description DTS header and bcm96856.dts is a simple DTS file for
|
|
Broadcom BCM96956 Reference board that only enable the UART port.
|
|
|
|
Signed-off-by: William Zhang <william.zhang@broadcom.com>
|
|
Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
|
|
---
|
|
arch/arm64/boot/dts/broadcom/bcmbca/Makefile | 3 +-
|
|
.../boot/dts/broadcom/bcmbca/bcm6856.dtsi | 103 ++++++++++++++++++
|
|
.../boot/dts/broadcom/bcmbca/bcm96856.dts | 30 +++++
|
|
3 files changed, 135 insertions(+), 1 deletion(-)
|
|
create mode 100644 arch/arm64/boot/dts/broadcom/bcmbca/bcm6856.dtsi
|
|
create mode 100644 arch/arm64/boot/dts/broadcom/bcmbca/bcm96856.dts
|
|
|
|
--- a/arch/arm64/boot/dts/broadcom/bcmbca/Makefile
|
|
+++ b/arch/arm64/boot/dts/broadcom/bcmbca/Makefile
|
|
@@ -2,4 +2,5 @@
|
|
dtb-$(CONFIG_ARCH_BCMBCA) += bcm94912.dtb \
|
|
bcm963158.dtb \
|
|
bcm96858.dtb \
|
|
- bcm963146.dtb
|
|
+ bcm963146.dtb \
|
|
+ bcm96856.dtb
|
|
--- /dev/null
|
|
+++ b/arch/arm64/boot/dts/broadcom/bcmbca/bcm6856.dtsi
|
|
@@ -0,0 +1,103 @@
|
|
+// SPDX-License-Identifier: (GPL-2.0+ OR MIT)
|
|
+/*
|
|
+ * Copyright 2022 Broadcom Ltd.
|
|
+ */
|
|
+
|
|
+#include <dt-bindings/interrupt-controller/irq.h>
|
|
+#include <dt-bindings/interrupt-controller/arm-gic.h>
|
|
+
|
|
+/ {
|
|
+ compatible = "brcm,bcm6856", "brcm,bcmbca";
|
|
+ #address-cells = <2>;
|
|
+ #size-cells = <2>;
|
|
+
|
|
+ interrupt-parent = <&gic>;
|
|
+
|
|
+ cpus {
|
|
+ #address-cells = <2>;
|
|
+ #size-cells = <0>;
|
|
+
|
|
+ B53_0: cpu@0 {
|
|
+ compatible = "brcm,brahma-b53";
|
|
+ device_type = "cpu";
|
|
+ reg = <0x0 0x0>;
|
|
+ next-level-cache = <&L2_0>;
|
|
+ enable-method = "psci";
|
|
+ };
|
|
+
|
|
+ B53_1: cpu@1 {
|
|
+ compatible = "brcm,brahma-b53";
|
|
+ device_type = "cpu";
|
|
+ reg = <0x0 0x1>;
|
|
+ next-level-cache = <&L2_0>;
|
|
+ enable-method = "psci";
|
|
+ };
|
|
+
|
|
+ L2_0: l2-cache0 {
|
|
+ compatible = "cache";
|
|
+ };
|
|
+ };
|
|
+
|
|
+ timer {
|
|
+ compatible = "arm,armv8-timer";
|
|
+ interrupts = <GIC_PPI 13 (GIC_CPU_MASK_SIMPLE(2) | IRQ_TYPE_LEVEL_LOW)>,
|
|
+ <GIC_PPI 14 (GIC_CPU_MASK_SIMPLE(2) | IRQ_TYPE_LEVEL_LOW)>,
|
|
+ <GIC_PPI 11 (GIC_CPU_MASK_SIMPLE(2) | IRQ_TYPE_LEVEL_LOW)>,
|
|
+ <GIC_PPI 10 (GIC_CPU_MASK_SIMPLE(2) | IRQ_TYPE_LEVEL_LOW)>;
|
|
+ };
|
|
+
|
|
+ pmu: pmu {
|
|
+ compatible = "arm,cortex-a53-pmu";
|
|
+ interrupts = <GIC_SPI 9 IRQ_TYPE_LEVEL_HIGH>,
|
|
+ <GIC_SPI 10 IRQ_TYPE_LEVEL_HIGH>;
|
|
+ interrupt-affinity = <&B53_0>, <&B53_1>;
|
|
+ };
|
|
+
|
|
+ clocks: clocks {
|
|
+ periph_clk:periph-clk {
|
|
+ compatible = "fixed-clock";
|
|
+ #clock-cells = <0>;
|
|
+ clock-frequency = <200000000>;
|
|
+ };
|
|
+ };
|
|
+
|
|
+ psci {
|
|
+ compatible = "arm,psci-0.2";
|
|
+ method = "smc";
|
|
+ };
|
|
+
|
|
+ axi@81000000 {
|
|
+ compatible = "simple-bus";
|
|
+ #address-cells = <1>;
|
|
+ #size-cells = <1>;
|
|
+ ranges = <0x0 0x0 0x81000000 0x8000>;
|
|
+
|
|
+ gic: interrupt-controller@1000 {
|
|
+ compatible = "arm,gic-400";
|
|
+ #interrupt-cells = <3>;
|
|
+ interrupt-controller;
|
|
+ reg = <0x1000 0x1000>, /* GICD */
|
|
+ <0x2000 0x2000>, /* GICC */
|
|
+ <0x4000 0x2000>, /* GICH */
|
|
+ <0x6000 0x2000>; /* GICV */
|
|
+ interrupts = <GIC_PPI 9 (GIC_CPU_MASK_SIMPLE(2) |
|
|
+ IRQ_TYPE_LEVEL_HIGH)>;
|
|
+ };
|
|
+ };
|
|
+
|
|
+ bus@ff800000 {
|
|
+ compatible = "simple-bus";
|
|
+ #address-cells = <1>;
|
|
+ #size-cells = <1>;
|
|
+ ranges = <0x0 0x0 0xff800000 0x800000>;
|
|
+
|
|
+ uart0: serial@640 {
|
|
+ compatible = "brcm,bcm6345-uart";
|
|
+ reg = <0x640 0x18>;
|
|
+ interrupts = <GIC_SPI 32 IRQ_TYPE_LEVEL_HIGH>;
|
|
+ clocks = <&periph_clk>;
|
|
+ clock-names = "refclk";
|
|
+ status = "disabled";
|
|
+ };
|
|
+ };
|
|
+};
|
|
--- /dev/null
|
|
+++ b/arch/arm64/boot/dts/broadcom/bcmbca/bcm96856.dts
|
|
@@ -0,0 +1,30 @@
|
|
+// SPDX-License-Identifier: (GPL-2.0+ OR MIT)
|
|
+/*
|
|
+ * Copyright 2022 Broadcom Ltd.
|
|
+ */
|
|
+
|
|
+/dts-v1/;
|
|
+
|
|
+#include "bcm6856.dtsi"
|
|
+
|
|
+/ {
|
|
+ model = "Broadcom BCM96856 Reference Board";
|
|
+ compatible = "brcm,bcm96856", "brcm,bcm6856", "brcm,bcmbca";
|
|
+
|
|
+ aliases {
|
|
+ serial0 = &uart0;
|
|
+ };
|
|
+
|
|
+ chosen {
|
|
+ stdout-path = "serial0:115200n8";
|
|
+ };
|
|
+
|
|
+ memory@0 {
|
|
+ device_type = "memory";
|
|
+ reg = <0x0 0x0 0x0 0x08000000>;
|
|
+ };
|
|
+};
|
|
+
|
|
+&uart0 {
|
|
+ status = "okay";
|
|
+};
|