mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-20 22:23:27 +00:00
d6d8851d12
Manually rebased: bcm27xx/patches-5.15/950-0421-Support-RPi-DPI-interface-in-mode6-for-18-bit-color.patch bcm27xx/patches-5.15/950-0706-media-i2c-imx219-Scale-the-pixel-clock-rate-for-the-.patch ramips/patches-5.15/810-uvc-add-iPassion-iP2970-support.patch Removed upstreamed: bcm27xx/patches-5.15/950-0707-drm-vc4-For-DPI-MEDIA_BUS_FMT_RGB565_1X16-is-mode-1-.patch[1] bcm27xx/patches-5.15/950-0596-drm-vc4-dpi-Add-option-for-inverting-pixel-clock-and.patch[2] ipq807x/0006-v5.16-arm64-dts-qcom-Fix-IPQ8074-PCIe-PHY-nodes.patch [3] ipq807x/0034-v6.1-arm64-dts-qcom-ipq8074-fix-PCIe-PHY-serdes-size.patch [4] ipq807x/0103-arm64-dts-qcom-ipq8074-fix-Gen2-PCIe-QMP-PHY.patch [5] ipq807x/0104-arm64-dts-qcom-ipq8074-fix-Gen3-PCIe-QMP-PHY.patch [6] ipq807x/0105-arm64-dts-qcom-ipq8074-correct-Gen2-PCIe-ranges.patch [7] ipq807x/0108-arm64-dts-qcom-ipq8074-fix-Gen3-PCIe-node.patch [8] ipq807x/0109-arm64-dts-qcom-ipq8074-correct-PCIe-QMP-PHY-output-c.patch [9] ipq807x/0132-arm64-dts-qcom-ipq8074-correct-USB3-QMP-PHY-s-clock-.patch [10] All other patches automatically rebased. 1. https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=v5.15.99&id=d2991e6b30020e286f2dd9d3b4f43548c547caa6 2. https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/drivers/gpu/drm/vc4/vc4_dpi.c?h=v5.15.100&id=8e04aaffb6de5f1ae61de7b671c1531172ccf429 3. https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/arch/arm64/boot/dts/qcom/ipq8074.dtsi?h=v5.15.99&id=a55a645aa303a3f7ec37db69822d5420657626da 4. https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/arch/arm64/boot/dts/qcom/ipq8074.dtsi?h=v5.15.99&id=d9df682bcea57fa25f37bbf17eae56fa05662635 5. https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/arch/arm64/boot/dts/qcom/ipq8074.dtsi?h=v5.15.99&id=7e6eeb5fb3aa9e5feffdb6e137dcc06f5f6410e1 6. https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/arch/arm64/boot/dts/qcom/ipq8074.dtsi?h=v5.15.99&id=e88204931d9a60634cd50bbc679f045439c4b91d 7. https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/arch/arm64/boot/dts/qcom/ipq8074.dtsi?h=v5.15.99&id=1563af0f28afd3b6d64ac79a2aecced3969c90bf 8. https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/arch/arm64/boot/dts/qcom/ipq8074.dtsi?h=v5.15.99&id=feb8c71f015d416f1afe90e1f62cf51e47376c67 9. https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/arch/arm64/boot/dts/qcom/ipq8074.dtsi?h=v5.15.99&id=69c7a270357a7d50ffd3471b14c60250041200e3 10. https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/arch/arm64/boot/dts/qcom/ipq8074.dtsi?h=v5.15.99&id=dd3d021ae5471d98adf81f1e897431c8657d0a18 Build system: x86_64 Build-tested: bcm2711/RPi4B, ramips/tplink_archer-a6-v3 Run-tested: bcm2711/RPi4B, ramips/tplink_archer-a6-v3 Signed-off-by: John Audia <therealgraysky@proton.me> Tested-by: Robert Marko <robimarko@gmail.com> #ipq807x/Dynalink WRX36 Tested-by: Stefan Lippers-Hollmann <s.l-h@gmx.de> #ipq807x/ax3600, x86_64/FW-7543B, ath79/tl-wdr3600, ipq806x/g10, ipq806x/nbg6817
61 lines
2.7 KiB
Diff
61 lines
2.7 KiB
Diff
From b810c8e719ea082e47c7a8f7cf878bc84fa2455d Mon Sep 17 00:00:00 2001
|
|
From: Arnd Bergmann <arnd@arndb.de>
|
|
Date: Tue, 8 Mar 2022 22:56:14 +0100
|
|
Subject: [PATCH 2/3] Kbuild: move to -std=gnu11
|
|
|
|
During a patch discussion, Linus brought up the option of changing
|
|
the C standard version from gnu89 to gnu99, which allows using variable
|
|
declaration inside of a for() loop. While the C99, C11 and later standards
|
|
introduce many other features, most of these are already available in
|
|
gnu89 as GNU extensions as well.
|
|
|
|
An earlier attempt to do this when gcc-5 started defaulting to
|
|
-std=gnu11 failed because at the time that caused warnings about
|
|
designated initializers with older compilers. Now that gcc-5.1 is
|
|
the minimum compiler version used for building kernels, that is no
|
|
longer a concern. Similarly, the behavior of 'inline' functions changes
|
|
between gnu89 using gnu_inline behavior and gnu11 using standard c99+
|
|
behavior, but this was taken care of by defining 'inline' to include
|
|
__attribute__((gnu_inline)) in order to allow building with clang a
|
|
while ago.
|
|
|
|
Nathan Chancellor reported a new -Wdeclaration-after-statement
|
|
warning that appears in a system header on arm, this still needs a
|
|
workaround.
|
|
|
|
The differences between gnu99, gnu11, gnu1x and gnu17 are fairly
|
|
minimal and mainly impact warnings at the -Wpedantic level that the
|
|
kernel never enables. Between these, gnu11 is the newest version
|
|
that is supported by all supported compiler versions, though it is
|
|
only the default on gcc-5, while all other supported versions of
|
|
gcc or clang default to gnu1x/gnu17.
|
|
|
|
Link: https://lore.kernel.org/lkml/CAHk-=wiyCH7xeHcmiFJ-YgXUy2Jaj7pnkdKpcovt8fYbVFW3TA@mail.gmail.com/
|
|
Link: https://github.com/ClangBuiltLinux/linux/issues/1603
|
|
Suggested-by: Linus Torvalds <torvalds@linux-foundation.org>
|
|
Acked-by: Marco Elver <elver@google.com>
|
|
Acked-by: Jani Nikula <jani.nikula@intel.com>
|
|
Acked-by: David Sterba <dsterba@suse.com>
|
|
Tested-by: Sedat Dilek <sedat.dilek@gmail.com>
|
|
Reviewed-by: Alex Shi <alexs@kernel.org>
|
|
Reviewed-by: Nick Desaulniers <ndesaulniers@google.com>
|
|
Reviewed-by: Miguel Ojeda <ojeda@kernel.org>
|
|
Signed-off-by: Arnd Bergmann <arnd@arndb.de>
|
|
Reviewed-by: Nathan Chancellor <nathan@kernel.org>
|
|
Signed-off-by: Masahiro Yamada <masahiroy@kernel.org>
|
|
---
|
|
Makefile | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -524,7 +524,7 @@ KBUILD_CFLAGS := -Wall -Wundef -Werror
|
|
-fno-strict-aliasing -fno-common -fshort-wchar -fno-PIE \
|
|
-Werror=implicit-function-declaration -Werror=implicit-int \
|
|
-Werror=return-type -Wno-format-security \
|
|
- -std=gnu89
|
|
+ -std=gnu11
|
|
KBUILD_CPPFLAGS := -D__KERNEL__
|
|
KBUILD_AFLAGS_KERNEL :=
|
|
KBUILD_CFLAGS_KERNEL :=
|