mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-21 14:37:57 +00:00
f4fb63d2ab
MDIO drivers were moved into their own sub directory of networking drivers. This has caused the AR40xx driver to probe before MDIO drivers and that wont work as it depends on the MDIO bus to be up so it can be fetched. Lets solve it by moving the AR40xx into MDIO folder so they get probed like before. Signed-off-by: Robert Marko <robert.marko@sartura.hr>
28 lines
826 B
Diff
28 lines
826 B
Diff
--- a/drivers/net/mdio/Kconfig
|
|
+++ b/drivers/net/mdio/Kconfig
|
|
@@ -27,6 +27,13 @@ config OF_MDIO
|
|
help
|
|
OpenFirmware MDIO bus (Ethernet PHY) accessors
|
|
|
|
+config AR40XX_PHY
|
|
+ tristate "Driver for Qualcomm Atheros IPQ40XX switches"
|
|
+ depends on HAS_IOMEM && OF && OF_MDIO
|
|
+ select SWCONFIG
|
|
+ help
|
|
+ This is the driver for Qualcomm Atheros IPQ40XX ESS switches.
|
|
+
|
|
if MDIO_BUS
|
|
|
|
config MDIO_DEVRES
|
|
--- a/drivers/net/mdio/Makefile
|
|
+++ b/drivers/net/mdio/Makefile
|
|
@@ -21,6 +21,8 @@ obj-$(CONFIG_MDIO_SUN4I) += mdio-sun4i.
|
|
obj-$(CONFIG_MDIO_THUNDER) += mdio-thunder.o
|
|
obj-$(CONFIG_MDIO_XGENE) += mdio-xgene.o
|
|
|
|
+obj-$(CONFIG_AR40XX_PHY) += ar40xx.o
|
|
+
|
|
obj-$(CONFIG_MDIO_BUS_MUX) += mdio-mux.o
|
|
obj-$(CONFIG_MDIO_BUS_MUX_BCM_IPROC) += mdio-mux-bcm-iproc.o
|
|
obj-$(CONFIG_MDIO_BUS_MUX_GPIO) += mdio-mux-gpio.o
|