mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-20 22:23:27 +00:00
d5bf46bbe8
OpenWRT's developer guide prefers having actual patches so they an be sent upstream more easily. However, in this case, Adding proper fields also allows for `git am` to properly function. Some of these patches are quite old, and lack much traceable history. This commit tries to rectify that, by digging in the history to find where and how it was first added. It is by no means perfect and also shows some patches that should have been long gone. Signed-off-by: Olliver Schinagl <oliver@schinagl.nl>
35 lines
948 B
Diff
35 lines
948 B
Diff
From 11425c9de29c8b9c5e4d7eec163a6afbb7fbdce2 Mon Sep 17 00:00:00 2001
|
|
From: Felix Fietkau <nbd@nbd.name>
|
|
Date: Thu, 9 Apr 2020 09:53:24 +0200
|
|
Subject: mediatek: Implement bad-block management table support
|
|
|
|
Submitted-by: Felix Fietkau <nbd@nbd.name>
|
|
---
|
|
drivers/mtd/nand/Kconfig | 4 ++++
|
|
drivers/mtd/nand/Makefile | 1 +
|
|
2 files changed, 5 insertions(+)
|
|
|
|
--- a/drivers/mtd/nand/Kconfig
|
|
+++ b/drivers/mtd/nand/Kconfig
|
|
@@ -15,6 +15,10 @@ config MTD_NAND_ECC
|
|
bool
|
|
depends on MTD_NAND_CORE
|
|
|
|
+config MTD_NAND_MTK_BMT
|
|
+ bool "Support MediaTek NAND Bad-block Management Table"
|
|
+ default n
|
|
+
|
|
endmenu
|
|
|
|
endmenu
|
|
--- a/drivers/mtd/nand/Makefile
|
|
+++ b/drivers/mtd/nand/Makefile
|
|
@@ -2,6 +2,7 @@
|
|
|
|
nandcore-objs := core.o bbt.o
|
|
obj-$(CONFIG_MTD_NAND_CORE) += nandcore.o
|
|
+obj-$(CONFIG_MTD_NAND_MTK_BMT) += mtk_bmt.o mtk_bmt_v2.o mtk_bmt_bbt.o mtk_bmt_nmbm.o
|
|
|
|
obj-y += onenand/
|
|
obj-y += raw/
|