mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-19 21:58:04 +00:00
5a2eb8082f
Add PHY driver for Airoha EN8811H PHY and package it as kernel module. The PHY needs to load firmware from rootfs, so there is no point in having the driver built-into the kernel. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
26 lines
764 B
Diff
26 lines
764 B
Diff
--- a/drivers/net/phy/Kconfig
|
|
+++ b/drivers/net/phy/Kconfig
|
|
@@ -384,6 +384,12 @@ config ROCKCHIP_PHY
|
|
help
|
|
Currently supports the integrated Ethernet PHY.
|
|
|
|
+config RTL8367S_GSW
|
|
+ tristate "rtl8367 Gigabit Switch support for mt7622"
|
|
+ depends on NET_VENDOR_MEDIATEK
|
|
+ help
|
|
+ This driver supports rtl8367s in mt7622
|
|
+
|
|
config SMSC_PHY
|
|
tristate "SMSC PHYs"
|
|
help
|
|
--- a/drivers/net/phy/Makefile
|
|
+++ b/drivers/net/phy/Makefile
|
|
@@ -95,6 +95,7 @@ obj-$(CONFIG_QSEMI_PHY) += qsemi.o
|
|
obj-$(CONFIG_REALTEK_PHY) += realtek.o
|
|
obj-$(CONFIG_RENESAS_PHY) += uPD60620.o
|
|
obj-$(CONFIG_ROCKCHIP_PHY) += rockchip.o
|
|
+obj-$(CONFIG_RTL8367S_GSW) += rtk/
|
|
obj-$(CONFIG_SMSC_PHY) += smsc.o
|
|
obj-$(CONFIG_STE10XP) += ste10Xp.o
|
|
obj-$(CONFIG_TERANETICS_PHY) += teranetics.o
|